Lucid Lynx takes about 3 minutes to start at boot up

Asked by Patrick Bulner on 2010-09-29

I am a Newbie. I Use dual boot Win XP/Ubuntu on my desktop PC. I see the following entry when I start my PC: "menuentry 'ubuntu, with Linux 2.6.32-25 generic--class ubuntu-- class gnu linux--class gnu--class os" -

generic recovery mode
memory test (memtest 86+)
memory test (memtest 86+, serial console 115200

I see 12 such entries. I select the first entry which is "menuentry ubuntu..." . Thereafter it takes about 3 minutes to start.

Would appreciate step by step procedure to overcome this problem.

Thanks

Question information

Language:
English Edit question
Status:
Expired
For:
Ubuntu grub2 Edit question
Assignee:
No assignee Edit question
Last query:
2010-10-11
Last reply:
2010-10-28
delance (olivier-delance) said : #1

Do you want first to reduce number of options in boot menu ?

Patrick Bulner (patrickbulner) said : #2

How do I reduce the number of options in the boot menu?

delance (olivier-delance) said : #3

Go to folder /boot, and note which version you are using. Usually, I should advise you to keep the two first one, but a you are able to boot, I know the first kernel is OK.
Open System->Administration->Synaptic (packet management), search the matching packet (use generic in search window to display list) and uninstall. The oldest versions should be removed from /boot folder.
Type command
     sudo upgrade-grub
This command will search the list of available Linux kernel and Windows OS, and rebuild grub menu (in file /boot/grub/grub.cfg).
Then reboot.

Patrick Bulner (patrickbulner) said : #4

Many thanks. Resolved problem 1.

Yet Lucid Lynx takes approx 3 to 4 minutes to start. I keep getting a
blank screen until it starts.

Patrick

On Wed, 2010-09-29 at 09:25 +0000, delance wrote:
> Your question #127263 on grub2 in ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/grub2/+question/127263
>
> delance proposed the following answer:
> Go to folder /boot, and note which version you are using. Usually, I should advise you to keep the two first one, but a you are able to boot, I know the first kernel is OK.
> Open System->Administration->Synaptic (packet management), search the matching packet (use generic in search window to display list) and uninstall. The oldest versions should be removed from /boot folder.
> Type command
> sudo upgrade-grub
> This command will search the list of available Linux kernel and Windows OS, and rebuild grub menu (in file /boot/grub/grub.cfg).
> Then reboot.
>

delance (olivier-delance) said : #5

Please, don't answer with previous message in your post.
Do you have this blank screen just after grub menu and before "5 dots" screen ?

Patrick Bulner (patrickbulner) said : #6

Yes! After grub menu.

delance (olivier-delance) said : #7

I have no ideas. Could you transform this question into a bug to get help from someone else.

delance (olivier-delance) said : #8

Hello, what's the status of your bug ?
If a answer solved your problem, could use button "Solved my problem" near the answer.
If you solved you problem by yourself, could you provide this solution for following users and mark question solved.
Else, I will have some time this week to have a look.
I will also request help from some colleagues.

Please tell is this Ubuntu installed in dual boot mode (not using Wubi) if yes please try to reinstall grub...

https://help.ubuntu.com/community/Grub2#Reinstalling%20GRUB%202

Sorry. The problem still remains. Lucid takes about 3 to 4 minutes to
boot.

On Tue, 2010-10-05 at 08:00 +0000, delance wrote:
> Your question #127263 on grub2 in ubuntu changed:
> https://answers.edge.launchpad.net/ubuntu/+source/grub2/+question/127263
>
> delance posted a new comment:
> Hello, what's the status of your bug ?
> If a answer solved your problem, could use button "Solved my problem" near the answer.
> If you solved you problem by yourself, could you provide this solution for following users and mark question solved.
> Else, I will have some time this week to have a look.
> I will also request help from some colleagues.
>

Yes this is Ubuntu in dual boot mode without wubi.

l On Tue, 2010-10-05 at 18:01 +0000, marcobra (Marco Braida) wrote:
> Your question #127263 on grub2 in ubuntu changed:
> https://answers.edge.launchpad.net/ubuntu/+source/grub2/+question/127263
>
> marcobra (Marco Braida) proposed the following answer:
> Please tell is this Ubuntu installed in dual boot mode (not using Wubi)
> if yes please try to reinstall grub...
>
> https://help.ubuntu.com/community/Grub2#Reinstalling%20GRUB%202
>

Sam_ (and-sam) said : #12

In case of remaining interest starting some requests.
Was it an update (e.g. 9.10 -> 10.04) or new installation ?
Anything changed in settings (configuration), partitions?
How old is the machine and what're hd specifics?

CLI:
sudo fdisk -l
lsb_release -d
dpkg -l linux-image* | grep ii
sudo lshw -C video

## where l is lower case of L

First off remove "quiet splash" in /etc/default/grub
https://wiki.ubuntu.com/Grub2#grub%20%28/etc/default/grub%29
Don't forget to update grub afterwards.
Backup the file:
sudo cp /etc/default/grub /etc/default/grub.orig ## choose whatever ending you like

Open the file and edit the line: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
gksudo gedit /etc/default/grub
Update Grub:
sudo update-grub

Update the system.
sudo apt-get update
sudo apt-get upgrade
sudo apt-get -f install

Cleanup package cache.
sudo apt-get clean
sudo apt-get autoremove

Run MemTest via boot menu. (It's this entry: memory test (memtest 86+)
(It can take a while, in case hours, so don't get nervous)

Run fsck to check filesystem on next reboot.
(Close all apps and save your work before running these in a terminal)
sudo touch /forcefsck
sudo reboot

In case grep errors from logfiles.
grep -i error /var/log/Xorg.0.log
gep -i error /var/log/syslog
grep -i error /var/log/dmesg

FYI investigation of those commands can be done by manpages.
e.g. via CLI:
man fsck
man apt-get
man dpkg
http://manpages.ubuntu.com/

Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x000ecf16

   Device Boot Start End Blocks Id System
/dev/sda1 1 4787 38451546 7 HPFS/NTFS
/dev/sda2 4788 4998 1690625 5 Extended
Partition 2 does not end on cylinder boundary.
/dev/sda5 4788 4998 1690624 82 Linux swap /
Solaris

Disk /dev/sdb: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xfe25fe25

   Device Boot Start End Blocks Id System
/dev/sdb1 * 1 4462 35840983+ 7 HPFS/NTFS
/dev/sdb2 4463 19457 120447337+ f W95 Ext'd (LBA)
/dev/sdb5 4463 9561 40957686 7 HPFS/NTFS
/dev/sdb6 9562 19086 76509531 83 Linux
/dev/sdb7 19087 19457 2980026 82 Linux swap /
Solaris

Description: Ubuntu 10.04.1 LTS

2.6.32-25.44
Linux kernel image for version 2.6.32 on i38

 *-display
       description: VGA compatible controller
       product: 82G33/G31 Express Integrated Graphics Controller
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 10
       width: 32 bits
       clock: 33MHz
       capabilities: msi pm bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:27 memory:fdf00000-fdf7ffff ioport:ff00(size=8)
memory:d0000000-dfffffff(prefetchable) memory:fda00000-fdafffff

$ df -h

Filesystem Size Used Avail Use% Mounted on
/dev/sdb6 72G 8.6G 60G 13% /
none 492M 288K 492M 1% /dev
none 497M 340K 496M 1% /dev/shm
none 497M 204K 496M 1% /var/run
none 497M 0 497M 0% /var/lock
none 497M 0 497M 0% /lib/init/rw

Patrick

Launchpad Janitor (janitor) said : #18

This question was expired because it remained in the 'Open' state without activity for the last 15 days.