Error: No such device

Asked by eddie larsen on 2010-08-13

I recently installed the new UBUNTU 10.04. it worked fine. I installed it with the windows installer on my e drive which is 17gb. I the secound time i rebooted the system. im running windows 7 64 bit. This error came: "error: no such device:" followed by a long string of numbers and letters. and under it, it says "grub rescue>". I have no clue on what to do. i cannot boot windows nor ubuntu. Please help me figure out what to do. I also made a cd with the ubuntu iso on it, but it won't start from cd just goes to the error.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu grub2 Edit question
Assignee:
No assignee Edit question
Last query:
Last reply:
Revision history for this message
eddie larsen (wingman92) said :
#1

When i installed it i used the windows installer and i Installed it on another partition then what my windows 7 is on. Does that matter or?

Revision history for this message
Andrea Corbellini (andrea.corbellini) said :
#2

Hello,

You should be able to use the Live CD following this steps:

1. Start your computer.
2. Insert the CD.
3. Reboot the computer using Ctrl+Alt+Del (or shutting it down and then re-starting it).

Following these steps, are you able to access the Live CD?
Could you write here at least the first letters/digits of the error message?

Thanks for your patience,
Andrea

Revision history for this message
delance (olivier-delance) said :
#3

https://help.ubuntu.com/community/Grub2#Reinstalling%20from%20LiveCD

Sometimes Grub2 failed to detect Seven at Ubuntu installation.
If it fail again to detect Seven, we will have to edit a grub file.
To prepare this possibility, when you are on Ubuntu LiveCD, could you type in a terminal (Applications->Accessories->Terminal) :
    sudo parted -l
where -l is lowercase "L", and post result.

Revision history for this message
delance (olivier-delance) said :
#4

Is your problem solved ? If not I can try to help, else, please, could you mark question "Solved".

Can you help with this problem?

Provide an answer of your own, or ask eddie larsen for more information if necessary.

To post a message you must log in.