Boot error: Gave up waiting for root device ALERT! /dev/disk/by-uuid/... does not exist. Dropping to a shell

Asked by Marcin Chady on 2010-07-29

I've been running Ubuntu 10.04 quite happily for about a month but now at boot i get:

Gave up waiting for root device (...) ALERT! /dev/disk/by-uuid/... does not exist. Dropping to a shell

Then I tried booting in the recovery mode, which also froze after printing:

[17.546335] sd 6:0:0:3: [sdg] Assuming drive cache: write through
(plus a couple similar lines)

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu grub2 Edit question
Assignee:
No assignee Edit question
Last query:
2010-08-12
Last reply:
2010-08-12
Marcin Chady (marcinchady) said : #2

Thanks Mark. I've opted for the GRUB_DISABLE_LINUX_UUID=true workaround for now and will see how it goes.

delance (olivier-delance) said : #3

Could you mark question as solved, to avoid someone have a look to answer ? Thank you

Mark Myers (mark-n4kss) said : #4

I am having this problem also with a new PC. I am too new to Linux/Ubuntu to know what to do.
I am not sure what Sudu or Grub are or where to find them. I assume it is akin to a dos command in windows.
I am trying to load my Windows 7 desktop with a dual boot of Ubuntu and am getting the same error.
I loaded Ubuntu on my laptop with very little problems. I'm trying to run before I've figured out how to crawl yet.
I need some step by step for dummies to get my desktop working in Ubuntu.
Thanks

Marcin Chady (marcinchady) said : #5

GRUB is a program that selects and loads an operating system (e.g. Ubuntu or Windows). When you reboot your laptop, do you get a menu of OS'es with GRUB somewhere in the title? If so, try the third link listed by Mark R above and follow the instructions in post #2, but instead of setting the boot device (the /dev/sdx stuff) add this to the command line: rootdelay=90

If this doesn't work, or you don't get the GRUB menu, then I'm not sure how to help. Reading the posts I noticed some people talk about waiting a few minutes after seeing the error, after which their system boots after all, but I haven't experienced it myself. Someone more knowledgeable may have to chip in here.

Marcin Chady (marcinchady) said : #6

Delance, I can't mark this issue as solved, because the original problem still occurs, i.e. the system freezes soon after logging in, although not every time. Since applying the GRUB_DISABLE_LINUX_UUID=true workaround the waiting for the root device alert seems to have stopped happening, though. In view of this, I think the title of this issue should be renamed back to its original description.

No, please create a separate question for the system freeze issue, which is a totally separate issue.

Please use this link to create the new question:

https://answers.launchpad.net/ubuntu/+addquestion

Please set this thread to "solved", which is about the "Gave up waiting for root device" issue.

No is better you do a new fresh question about your sound issue from here:

https://answers.launchpad.net/ubuntu/+addquestion

( i also change now the original content to better match you solved uuid issue )

Please always ask one question for a thread.

Thanks

Can you help with this problem?

Provide an answer of your own, or ask Marcin Chady for more information if necessary.

To post a message you must log in.