Grub delayed by external USB hard drive

Asked by Christopher

I noticed quite some time ago that my desktop went to Grub far faster than on my laptop. I had assumed (dumb - never assume) that it was a matter of processor speed, but it's actually due to my Seagate Free Agent Go USB hard drive.

If I unplug it prior to booting, grub (grub2) appears beteen one or two seconds after the brief Lenovo splash screen, but it takes more than ten seconds for grub to appear when the drive is plugged in.

I tried putting any and all autorun files from the USB hard drive in a folder, but it made no difference.

The desktop computer also has an external USB hard drive, but grub isn't delayed at all. It may not have the same Windows tools included, as it it from a different manufacturer (Verbatim).

I'm running Karmic on one partition and Lucid on the other, and they and all previous versions back to Hardy (my first real Ubuntu version) have had the same symptom.

I imagine grub is looking for something bootable on the drive, but that doesn't explain why it doesn't happen with my desktop, or why it's not looking for one on a flash drive. My BIOS isn't even capable of booting from a USB device on the laptop.

Question information

English Edit question
Ubuntu grub Edit question
No assignee Edit question
Last query:
Last reply:
Revision history for this message
P├ętur Ingi Egilsson (petur) said :

Grub does not look for anything bootlable on other drives. It simply reads it's configuration file.

On the other hand, your laptop could be configured to attempt booting from your USB drive before it attempts to boot from the on-board drive.

I suggest you look at your computers BIOS configuration, if your unfamiliar with it refer to your laptops documentation. (You can find them on the manufacturers website)

Revision history for this message
Christopher (soft-kristal) said :

I'm quite familiar with the BIOS, CMOS and all other DOS stuff, having been subjected to Windows 3.0 many years ago.

This laptop is four years old and doesn't even have a USB boot option, but even though there is no floppy drive, there is an option to boot from floppy, which may be what the BIOS thinks the USB drive is.

I'm running something I don't want to stop until it's finished, but after it's done, I'll reboot and see if 'floppy drive' is priority over the hard drive. I'm pretty sure I had it set to CD/hard drive/floppy drive, but it's been a while since I've looked at the BIOS.

Revision history for this message
Christopher (soft-kristal) said :

The BIOS was set to FDD/CD/HDD. I set it to CD/HDD/FDD and rebooted. It still took 10 seconds to get to the Grub menu. I then set it to HDD/CD/FDD and rebooted with the same result.

There are some Ubuntu ISO files on the USB hard drive. Could Grub be looking at those? Other than that, there are a few Home backups from when I had to reinstall, but no boot folders.

Revision history for this message
actionparsnip (andrew-woodhead666) said :

Do you have the latest BIOS for your motherboard?

Revision history for this message
Christopher (soft-kristal) said :

Good question. Lenovo has a BIOS flash tool for Windows, but doesn't have an equivalent in Linux.

Revision history for this message
Christopher (soft-kristal) said :

I can flash the BIOS from VirtualBox - would that make sense?

Revision history for this message
actionparsnip (andrew-woodhead666) said :

No do not do that, you may have to create a USB based Windows install or see if it can be done via DOS

Can you help with this problem?

Provide an answer of your own, or ask Christopher for more information if necessary.

To post a message you must log in.