How to restore ubuntu boot splash

Asked by Steven Sroka on 2009-10-16

I just installed Windows 7, reinstalled GRUB (as always when Windows is involved....), but now there is no splash screen during boot. Just text running down the screen. How do I revert it back to the original configuration?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu grub Edit question
Assignee:
No assignee Edit question
Solved by:
Cristi Nistor
Solved:
2009-10-19
Last query:
2009-10-19
Last reply:
2009-10-19

This question was reopened

Cristi Nistor (cristi-nistor) said : #1

https://help.ubuntu.com/community/RecoveringUbuntuAfterInstallingWindows

If you need to restore GRUB after Win installation. Did you notice something relevant when you saw "text running down the screen'?

Steven Sroka (lin-unix) said : #2

Thanks Cristi Nistor, that solved my question.

Steven Sroka (lin-unix) said : #3

No nothing relevant is being displayed on the screen. I restored GRUB originally using the information on the website, so I know it doesn't talk about the Ubuntu boot splash screen. Any other ideas?

Sam_ (and-sam) said : #4

Depends which GRUB.
Just check files menu.lst or grub if there is an entry: quiet splash instead of nosplash or no entry.

Steven Sroka (lin-unix) said : #5

Its says "ro quiet splash" in the boot parameters and "quiet splash" is set in "additional options"

Cristi Nistor (cristi-nistor) said : #6

Now I think is more clear.
You can install StartUpmanager using in a terminal the command:

sudo apt-get install startupmanager

and to run it

gksudo startupmanager (or System --> Administration --> StartUp-Manager

and in the second tab you have Appearance and you can choose your desired theme (or just the default one) for usplash.

Good luck

Sam_ (and-sam) said : #7

Or try:
sudo update-initramfs -u

Steven Sroka (lin-unix) said : #8

I've tried both of the above options but its not working. To be clear the splash screen does load up at first and the loading bar bounces back and forth then the screen turns blank and white text runs down the screen at which point the Ubuntu login appears.

During the boot, the text that appears shows what components are loaded up during boot time and everything is loaded as "OK"

Best Cristi Nistor (cristi-nistor) said : #9

You have to check if is a modification in your /etc/fstab file regarding the swap partition.

This is the fix:

Run in a terminal the command:

sudo blkid -c /dev/null

Check that the UUID for the swap partition in /etc/initramfs-tools/conf.d/resume is the same as the UUID for the swap partition you got from blkid. Edit the file if necessary.

After this run the command

sudo update-initramfs -u

Reboot.

Steven Sroka (lin-unix) said : #10

Thanks Cristi Nistor, that solved my question.