How to BOOT from harddisc

Asked by hthomsen

I've just installed Ubuntu 8.10 for the first time on my T40. There is no other OS on the hardisc.

My problem is that the lab-top only boots with the installation CD inserted. I get the startupwindow ( select language etc), and then I have to choose 'startup from first harddisc'. Then everything starts perfectly. If I dont use the installation disc, I just get the message that no operating system is found.

How can I change that ?

Question information

English Edit question
Ubuntu grub Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
Bernd Schlapsi (bernd-sch) said :

Do you really have successfully installed Ubuntu on your system? It seems that the installation process doesn't work correctly

Revision history for this message
hthomsen (thomsnerne) said :

Hi, that might be the case. I can only see that Unbuntu seems to work fine. How can I see if it is correctly installed ? btw, I have tried to install twice to see if second time was better.

Revision history for this message
Bernd Schlapsi (bernd-sch) said :

How did you install your system? Did you click the "install"-icon and followed all the steps to setup your system? Did a message appear that asked you if you would like to use the live cd or just reboot your new installed system?

If you look under the menu "Places"->Computer what do you see there?

Revision history for this message
hthomsen (thomsnerne) said :

Since there we no os on the computer, I booted directly in the installation disc.

I followed the whole process step by step. I do not recall any messages regarding the use of live CD or reboot. At the end of the installation process I was asked to remove the disc from the drive, and then re-boot.

If I look at the 'places'--> computer, I see two icons. One showing the Ubuntu installation disc - the other showing an icon called 'Filsystem' (I guess it would have been filesystem in eng.)

Revision history for this message
Bernd Schlapsi (bernd-sch) said :

That sounds a little bit strange to me. If the installation process works well, why you couldn't boot into your system??

You could try to install the system with the "Alternate installer". The look is a little bit old-fashioned but it also has a few more option , but I think the installation process is easy enough

Revision history for this message
marcobra (Marco Braida) (marcobra) said :

I suggest you to reinstall Ubuntu.

But before to start install Ubuntu check, by entering into your pc BIOS setup, there is not some kind of boot protection (sometimes called virus protection) active.

Hope this helps

Revision history for this message
elysianfields (elysianfields44) said :

It would be a good idea to check the BIOS settings, as suggested above. You can do so by accessing the BIOS menu during startup; the shortcut key for that varies depending on your BIOS setup. It might be that it's booting from CD by default (although if Ubuntu is installed and there's no CD it should look on your hard disk next).

Also, to check if it was installed in the first place, you could check the partitions of your hard drive. From terminal, type: less /etc/fstab to list the partitions mounted during system startup; what does it say?

Revision history for this message
hthomsen (thomsnerne) said :


BIOS setting seems OK. Using the mentioned command gives the response:

# /etc/fstab: static file system information.
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
# /dev/sda2
UUID=148c4fe3-5c71-4b7b-a312-076682d80da4 / ext3 relatime,errors=remount-ro 0 1
# /dev/sda5
UUID=6d153eb3-ddf2-4111-9860-6c04a16ca469 none swap sw 0 0
/dev/scd0 /media/cdrom0 udf,iso9660 user,noauto,exec,utf8 0 0

Revision history for this message
David Alvarez (letitbe2007) said :

I had this problem after changing bios to look at the cd first.
I restored the original bios options, by hitting 'reset to default' in the bios menu.
I took out the battery waited a little while then putt it back in.
Don't know why, but it worked!

Hope this helps:)

Revision history for this message
hthomsen (thomsnerne) said :


After reinstalling, system boots well

Thank you for your help :-))