Many items in the start up list

Asked by Mohammad Alhobayyeb on 2009-01-23

Why I am having all this list?

Ubuntu 8.10, kernel 2.6.27-9-generic
Ubuntu 8.10, kernel 2.6.27-9-generic (recovery mode)
Ubuntu 8.10, kernel 2.6.27-7-generic
Ubuntu 8.10, kernel 2.6.27-7-generic (recovery mode)
Ubuntu 8.10, memtest86+
Other operating systems:
Windows Vista/Longhorn (loader)

Why it's not only like that?
Ubuntu 8.10, kernel 2.6.27-9-generic
Ubuntu 8.10, kernel 2.6.27-9-generic (recovery mode)
Ubuntu 8.10, memtest86+
Other operating systems:
Windows Vista/Longhorn (loader)

Does this mean I have two Ubuntu installations????
One with kernel 2.6.27-9-generic and the other with kernel 2.6.27-7-generic??

Is this normal or not??

Question information

English Edit question
Ubuntu grub Edit question
No assignee Edit question
Solved by:
marcobra (Marco Braida)
Last query:
Last reply:
Wim (launchpad-xs4all) said : #1


The grub loader gives you actually 3 choises:
1. start Ubuntu (normal or Recovery_Mode)
2. check the PC-memory with memtest386+
3. boot other OS (in your case Vista)

Sometimes something can go wrong during updating Ubuntu,
therfore grub always lets you choose between the newest version U-08.10 kernel-build-9 and your previous version U-08.10 kernel-build-7...

So your menu is normal! And (prediction) after the next update, another 2 lines comes on top of that menu.
But "nil desperando" ...
YOU can choose to see only the 2 most new kernels:

There is a file /boot/grub/menu.lst which grub reads starttime; in that file YOU can set how grub must start !

I will explain here how to do that:
.1. open a terminal window (in your menu <Applications>,... <Accesoires>,... <Terminal>,...
.2. in that windows enter the next command, what will ask you for your password (this is normal)

   sudo nano /boot/grub/menu.lst

.3. you now see the Nano-Editor, we skip to line 98/100 by entering the next command; note that ^W here means pressing Ctrl-W ...


.4. you will see 3 lines with the word howmany, explaining how it works...
change the LAST of those lines, so that the word ALL is replced by the digit 2, then it says:

   # howmany=2

.5. in the end you want to SAVE the, do that by pressing Ctrl-Ooh


.6. close the nano-editor bij the key-combination Ctrl-X


.7. close the terminal window, you can choose between the quick-combination
or type in the command

Now reboot the system; today you see no change (because you already had 2 kernels in the list). But after the next update of your Ubuntu, you will se that the first line changed in

Ubunti-08.10, kernel...-10-...

and that the current FIRST line is moved to the THIRD.

Does this solve your problem?!?
Keep enjoying Ubuntu ;)

Your system is ok and is absolutely good to have more than one linux kernel installed on the pc...

Ubuntu 8.10, kernel 2.6.27-9-generic
Ubuntu 8.10, kernel 2.6.27-7-generic

But if you want only one kernel installed ( the latest ) you can remove previous installed kernels

If you want to remove the linux-image-2.6.27-7-generic you must simply remove it...

Open a Terminal from the menu Applications → Accessories → Terminal and to get all the packages related to the kernel 2.6.27-7-generic, type:

dpkg -l | grep -i 2.6.27-7-generic

Then remove them:

sudo apt-get --purge remove linux-image-2.6.27-7-generic linux-headers-2.6.27-7-generic

(if the system ask you a password give your user password, you will not see nothing when you type it, then press enter)

Hope this helps

george (gk-joimail) said : #3

I would like to ask a follow up question to this string, please

I understand al the aforementioned steps, however in my case the Grub loader gives me this option.

Ubuntu 8.10, kernel 2.6.27-9-generic
Ubuntu 8.10, kernel 2.6.27-9-generic (recovery mode)
Ubuntu 8.10, kernel 2.2.24-23-generic
Ubuntu 8.10, kernel 2.2.24-23-generic (recovery mode)
Ubuntu 8.10, memtest86+
Other operating systems:
Windows Media Center XP
Windows NT/2000/XP

My question is how to remove the NT/2000/XP option or should I not because it's needed for the Media Center to function? I have the Media Center set as the default start-up


Mohammad Alhobayyeb (mih1406) said : #4

It gives me:
ii linux-headers-2.6.27-7-generic 2.6.27-7.16 Linux kernel headers for version 2.6.27 on x
ii linux-image-2.6.27-7-generic 2.6.27-7.16 Linux kernel image for version 2.6.27 on x86
ii linux-restricted-modules-2.6.27-7-generic 2.6.27-7.12 Non-free Linux kernel modules for version 2.

Do i have to remove all of them or only the first two??

Wim (launchpad-xs4all) said : #5


do NOT remove the Windows-options from the grub menu, otherwise you can nott boor to that Windows-version anymore!

Did you succeed to set this in /boot/grub/menu.lst:

  # howmany=2

Because, if you did; no more than 2 different kernels will be stated here (after the next kernel-update).

  grep howmany= /boot/grub/menu.lst

must have as last output-line

  # howmany=2

If this is correct, just wait until the next Ubuntu-kernel update... Then you will only see startup lines of the LAST TWO kernels: the newest one and the previous one.

Is this answer sufficient for you ?!?

george (gk-joimail) said : #6

It answers my question, but I don't know about MIH1406's question


Mohammad Alhobayyeb (mih1406) said : #7

howmany did not solve it
I have put it to 1 but also nothing changed

Wim (launchpad-xs4all) said : #8

The change in the grub-menu-list is done at the first next time the Ubuntu-update is done, e.g. when you go from the kernel- to kernel- ... At that moment the grub menu is re-created and the item "howmany=2" is used to shorten the list.

So please try to update your Ubuntu-version using Synaptic-Software-Manager, and check whether the list is modified.

Please try to install and use to manage how many kernel you want to see into your GRUB menu the startupmanager package.

Please first enable the universe repository:

Open System → Administration → Software sources → [ Tab Ubuntu software ]
enable "Community Maintained open source software (universe)"
Close and confirm the repository reload.

Then open a Terminal from the menu Applications → Accessories → Terminal and type:

sudo aptitude update
sudo aptitude install startupmanager

give your user password when requested, you don't see nothing when you type it, then press enter.

Then you will find the startupmanager under the menu System → Administration → Startup manager

Hope this helps

Mohammad Alhobayyeb (mih1406) said : #10

Thanks marcobra, that solved my question.

By the way using startupmanager or modifying by hand your /boot/grub/menu.lst don't remove your old kernels.

I don't like to hide my installed kernels from Grub menu, i like to have all installed kernel showed.

When a new kernel is released i usually keep for a while the just released and the precedent working kernel.
Then if the pc is working good: i mean with audio, video and other hardware then i remove the old kernel.

Hope this helps

Mohammad Alhobayyeb (mih1406) said : #12

How can I remove the old kernel??