after cloning ubuntu to a new hdd neither hdd will self-boot

Asked by Jeff Lowe

After attempting to clone a hard drive with Ubuntu7.10 using Acronis True Image, neither the original nor back-up copy is self-bootable. They can be booted using the Ubuntu7.10 Install CD (live CD?). But not, oddly enough, with later versions of Ubuntu.
I'm not confident with my command line skills, but I was able to compare the File System with another healthy version of Ubuntu (8.04) and see that Acronis appears to have deleted 20 items in the "boot" file, one of which is GRUB.
So what's the problem? I can still get to the many personal files on the original hard drive, just have to be patient while the live CD boots it up.
Thing is, it belongs to a lady friend who's computer skills are even worse than mine; and she still wants a backup copy.
How can we:
1. Restore the Grub file, or whatever it is we have to do to make the hard drives self-bootable, or
2. Maybe migrate all her personal files (they're not in separate partitions) to another hard drive with an up-to-date version of Ubuntu on it.

Be nice if I could get this done for Christmas, eh?

Thanx, Jeff

Question information

English Edit question
Ubuntu grub Edit question
No assignee Edit question
Solved by:
Jeff Lowe
Last query:
Last reply:
Revision history for this message
john (no2498) said :

did you make 1 a slave ?

Revision history for this message
Jeff Lowe (jefflowe) said :

No, John, 1 was left as a Master.
Please excuse the delay in replying - have been away for an extended family Xmas. Hope yours was as good.

Revision history for this message
Wim (launchpad-xs4all) said :


Boot from the live-CD,
start your Ubuntu-version on hard disk;
then a terminal,
give these commands:

     cat /etc/fstab

(see on which device the filesystem / (Root) is placed, and use that {DeviceName} in the next commandline [=1 line !] )

   /sbin/grub-install --no-floppy
                     --recheck {DeviceName}

(perhaps the last command must be preceded with sudo, so it becomes:)

   sudo /sbin/grub-install --no-floppy
                     --recheck {DeviceName}

Reboot and try if grub is complete again.

Revision history for this message
Jeff Lowe (jefflowe) said :


Worked like a charm !

Many thanx.