update-grub and Wubi

Asked by merlwiz79 on 2008-10-30

In Linux Mint we use grub-gfxboot.
In Linux Mint 5(hardy package base) I got grub-gfxboot to work with Wubi.
It would use groot=()/mint/disks

I made a custom Ubuntu Intrepid rc disk with grub-gfxboot and it used groot=(hd2,0)/ubuntu/disks

Is their anything I need to change to get groot back to ()/ubuntu/disks?
The only thing I changed was grub to grub-gfxboot so it has to be this that changed it.

Thanks for any help that can be provided.
If you need my current version of grub-gfxboot you can download it here:
http://www.4shared.com/file/69056187/b8f96b11/grub-gfxboot-all.html

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu grub Edit question
Assignee:
No assignee Edit question
Solved by:
merlwiz79
Solved:
2008-11-09
Last query:
2008-11-09
Last reply:
2008-10-31

Ubuntu is not Linux Mint. You should ask them for help with this.

There are a few reasons Ubuntu does not do what "makes Linux Mint great" and this is one of them.

I also would suggest not testing against packages not in the main repositories.

merlwiz79 (merlwiz79) said : #2

Sorry, Forgot to mention that I am the one who makes the grub-gfxboot for Linux Mint.
In Hardy 8.04.1 grub-gfxboot uses groot=()/ubuntu/disks for Wubi installs.
In Intrepid it uses groot=(hdX,X)/ubuntu/disks.
Is their any changes in the grub package in Intrepid that would fix this?
I have been using grub 0.97-29ubuntu45 to update grub-gfxboot.

I think grub-gfxboot could be added to Ubuntu's repositories if these were fixed:
add ucf to update-grub
add varargs.diff
add uuid.diff and uuid_doc.diff
add convert_to_uuid to update grub
add convert_kopt_to_uuid to update grub
add uuid to update-grub
fix for Wubi installs
anything else I left out.

What I have added from grub 0.97-29ubuntu45:
quiet.diff
gpt.diff
grub-install_storeversion.diff
prepend_virtio_devices.diff
edd-device-map.diff
grub-install_better_raid.diff
last good boot in update grub
is_removable & check_removable in update-grub
loop_file for kopt in update-grub
quiet option in update-grub

Any help would be appreciated.

merlwiz79 (merlwiz79) said : #3

It was grub-installer messing it up.
Thanks for the input though.