Can't boot W-XP from Grub ... "error 29: Disk write error"

Asked by tc on 2008-09-20

Folks,

I'm afraid I'm a real beginner ... Got my very first copy of Ubuntu last night [never used UNIX before] ... (backed up all my stuff) and installed.

I get an error at Grub when I try to boot XP [Media Centre Edition] ... Ubuntu is working fine (I think).

Anyhow, I searched this forum for similar problems ... found the solution ... but can't apply the solution because I don't understand it.

Here's what I found:

"... 2. If I load Ubuntu from the current grub I get "error 29 disk write error press any key to continue". ...
Can you anyone please help me put in the windows option and get rid of this error 29 problem?

Sam Cater said on 2007-06-30:

then error 29 thing is easy.
From ubuntu go to /boot/grub/menu.lst and remove savedefault from the menu entry

My question:
From Ubuntu??? Is this something like a MS-DOS window ... where do I open this window ... Sam's answer is for someone who knows Ubuntu a little ... I know nothing about Ubuntu ...

Please help ...

tc

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu grub Edit question
Assignee:
No assignee Edit question
Solved by:
Wyatt Smith
Solved:
2008-09-21
Last query:
2008-09-21
Last reply:
2008-09-21
Wyatt Smith (wyatt-smith) said : #1

You need to edit a file in Ubuntu, so you must boot to Ubuntu. Next open up the terminal:
Applications > Accessories > Terminal

From the terminal type
sudo gedit /boot/grub/menu.lst
enter you password (the cursor will not move when you do this)

Scroll down to the bottom and find the section referring to your windows installation. Remove the line that says savedefault. Save the file and then reboot.

tc (t-tigger) said : #2

I've made the change, still no joy ...

Menu entry now looks like [and I have rebooted since]:

# This entry automatically added by the Debian installer for a non-linux OS
# on /dev/sda1
title Windows XP Media Center Edition
root (hd0,0)
makeactive
chainloader +1

Wyatt Smith (wyatt-smith) said : #3

tc

Try out these changes

title Windows XP Media Center Edition
rootnoverify (hd0)
chainloader +1

If this does not bring joy, post the entire menu.lst file

tc (t-tigger) said : #4

WW,

It didn't work ... I didn't get the error 29 this time; instead when I choose to boot XP; the window went blank (apparently waitng for something to load) ... I waited over 20s ... got fed-up waiting ... hit enter ... and back at the screen where the choice is first given ...
So, only Ubuntu loads ... guess we're back at square one in a different car ...

Here's the code:

# menu.lst - See: grub(8), info grub, update-grub(8)
# grub-install(8), grub-floppy(8),
# grub-md5-crypt, /usr/share/doc/grub
# and /usr/share/doc/grub-doc/.

## default num
# Set the default entry to the entry number NUM. Numbering starts from 0, and
# the entry number 0 is the default if the command is not used.
#
# You can specify 'saved' instead of a number. In this case, the default entry
# is the entry saved with the command 'savedefault'.
# WARNING: If you are using dmraid do not use 'savedefault' or your
# array will desync and will not let you boot your system.
default 0

## timeout sec
# Set a timeout, in SEC seconds, before automatically booting the default entry
# (normally the first entry defined).
timeout 20

## hiddenmenu
# Hides the menu by default (press ESC to see the menu)
#hiddenmenu

# Pretty colours
#color cyan/blue white/blue

## password ['--md5'] passwd
# If used in the first section of a menu file, disable all interactive editing
# control (menu entry editor and command-line) and entries protected by the
# command 'lock'
# e.g. password topsecret
# password --md5 $1$gLhU0/$aW78kHK1QfV3P2b2znUoe/
# password topsecret

#
# examples
#
# title Windows 95/98/NT/2000
# root (hd0,0)
# makeactive
# chainloader +1
#
# title Linux
# root (hd0,1)
# kernel /vmlinuz root=/dev/hda2 ro
#

#
# Put static boot stanzas before and/or after AUTOMAGIC KERNEL LIST

### BEGIN AUTOMAGIC KERNELS LIST
## lines between the AUTOMAGIC KERNELS LIST markers will be modified
## by the debian update-grub script except for the default options below

## DO NOT UNCOMMENT THEM, Just edit them to your needs

## ## Start Default Options ##
## default kernel options
## default kernel options for automagic boot options
## If you want special options for specific kernels use kopt_x_y_z
## where x.y.z is kernel version. Minor versions can be omitted.
## e.g. kopt=root=/dev/hda1 ro
## kopt_2_6_8=root=/dev/hdc1 ro
## kopt_2_6_8_2_686=root=/dev/hdc2 ro
# kopt=root=UUID=94ce07a9-94c3-4103-9290-c357bc1b4892 ro

## Setup crashdump menu entries
## e.g. crashdump=1
# crashdump=0

## default grub root device
## e.g. groot=(hd0,0)
# groot=(hd0,1)

## should update-grub create alternative automagic boot options
## e.g. alternative=true
## alternative=false
# alternative=true

## should update-grub lock alternative automagic boot options
## e.g. lockalternative=true
## lockalternative=false
# lockalternative=false

## additional options to use with the default boot option, but not with the
## alternatives
## e.g. defoptions=vga=791 resume=/dev/hda5
# defoptions=quiet splash

## should update-grub lock old automagic boot options
## e.g. lockold=false
## lockold=true
# lockold=false

## Xen hypervisor options to use with the default Xen boot option
# xenhopt=

## Xen Linux kernel options to use with the default Xen boot option
# xenkopt=console=tty0

## altoption boot targets option
## multiple altoptions lines are allowed
## e.g. altoptions=(extra menu suffix) extra boot options
## altoptions=(recovery) single
# altoptions=(recovery mode) single

## controls how many kernels should be put into the menu.lst
## only counts the first occurence of a kernel, not the
## alternative kernel options
## e.g. howmany=all
## howmany=7
# howmany=all

## should update-grub create memtest86 boot option
## e.g. memtest86=true
## memtest86=false
# memtest86=true

## should update-grub adjust the value of the default booted system
## can be true or false
# updatedefaultentry=false

## should update-grub add savedefault to the default options
## can be true or false
# savedefault=false

## ## End Default Options ##

title Ubuntu 7.10, kernel 2.6.22-14-generic
root (hd0,1)
kernel /boot/vmlinuz-2.6.22-14-generic root=UUID=94ce07a9-94c3-4103-9290-c357bc1b4892 ro quiet splash
initrd /boot/initrd.img-2.6.22-14-generic
quiet

title Ubuntu 7.10, kernel 2.6.22-14-generic (recovery mode)
root (hd0,1)
kernel /boot/vmlinuz-2.6.22-14-generic root=UUID=94ce07a9-94c3-4103-9290-c357bc1b4892 ro single
initrd /boot/initrd.img-2.6.22-14-generic

title Ubuntu 7.10, memtest86+
root (hd0,1)
kernel /boot/memtest86+.bin
quiet

### END DEBIAN AUTOMAGIC KERNELS LIST

# This is a divider, added to separate the menu items below from the Debian
# ones.
title Other operating systems:
root

# This entry automatically added by the Debian installer for a non-linux OS
# on /dev/sda1

title Windows XP Media Center Edition
rootnoverify (hd0)
chainloader +1

Best Wyatt Smith (wyatt-smith) said : #5

tc

Sorry, I think you may also have to specify the partition.

title Windows XP Media Center Edition
rootnoverify (hd0,0)
chainloader +1

ronnie_libra (ronnie-libra) said : #6

it seem that ubuntu or windows is missing information to boot its operating system,you said you can still use ubuntu?If you tried all those suggestions above, i think your having hard disk error that ubuntu may not fix automatically,I suggest that you must make sure that your hardisk is not causing this problem.If you can erase your entire disk pls. try it,if your hard drive is maxtor use maxtor utility,or other hardisk utility.After you erase the disk, Install windows first,partition the disk for windows, and leave free space for ubuntu system to be installed after windows.Backup all your important files,you can use ubuntu live cd.Read hard disk utility manual carefully....

To help you better we need some infos about your system so please open a Terminal from the menu Applications->Accessories->Terminal and type:

sudo fdisk -l

-l parameter is lower of -L

give your user password when requested, you don't see nothing when you type it, then press enter.

Please copy and paste result here.

Thank you

tc (t-tigger) said : #8

Thanks WWSmith36, that solved my question.

tc (t-tigger) said : #9

Marcobra,

Just to reply to you too; the result of your query is:

**********************************************************************
Disk /dev/sda: 80.0 GB, 80026361856 bytes
255 heads, 63 sectors/track, 9729 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x0244da81

   Device Boot Start End Blocks Id System
/dev/sda1 1 2353 18900441 7 HPFS/NTFS
/dev/sda2 * 2354 9391 56532735 83 Linux
/dev/sda3 9392 9697 2457945 5 Extended
/dev/sda4 9698 9729 257040 88 Linux plaintext
/dev/sda5 9392 9697 2457913+ 82 Linux swap / Solaris

**********************************************************************

Although my initial query is solved; I've another ... but I think I know how to fix it ...
- I installed XP [no partition].
- I installed UBUNTU next ... UBUNTU offered a wizard which asked how much disk space I should allow IT to have ... I allotted 18 GB from my total 80 GB.
- In XP: I notice my C-Drive shows total size 18 GB.
- In UBUNTU: I notice my C-Drive shows total size 18 GB.
- Lovely ... just lovely ...

I'm fast losing patience with this thing (not with ye all ... just don't understand why my choice seems to be screwed up).
Anyhow, tomorrow I'll format my c-drive again ... install XP [see if I've an option to create a partition at this stage] and when I install UBUNTU afterwards I'll thread slowly ...

Many thanks for all the help folks ...

tc