error 15 in grub on second HD

Asked by rjacobsen

I installed Ubuntu 6.1 on a second HD (the first has XP) and Grub on it (hd1,0). Grub appears when I boot through the second HD, but choosing any OS causes an "error 15: file not found" to show. The following are the initial lines on it, as it appears when I boot:

root (hd1,0)
kernel /boot/vmlinuz-2.6.17-10-generic root=/dev/hdb1 ro quiet splash
initrd /boot/initrd.img-2.6.17-10-generic

I notice that when I change the first one, I get another error, so it should be right that way. I guess the second line is where the problem resides, as Grub doesn't seem to be finding things on their places. Through WinXP I can see that the kernel file on its place ( at /boot/), as well as the initrd file. I am relatively new to Linux, so I'm having problems trying to figure out what to do. I tried to check things on the HD through the Ubuntu LiveCD, but it doesn't give me access to those, therefore it doesn't look like I can modify any installed files. I tried several ways to install Ubuntu through the LiveCD, but only the one with the root (/) and swap partitions worked, and not always it went through (most of the times it would keep saying the root partition hadn't been chosen, no matter what -- I saw several people complaining of this also).

In summary, my system has partitions hda1 and hda2 with XP, and hdb1 (root) and hdb5 (swap) -- I couldn't figure out why the #5 -- with Ubuntu; I kept the original MBR on the HD1, the Grub boot manager was put on the second HD.

If there's no easy way out of this, I wonder if there's a way to make a boot CD in order to boot into the installed Ubuntu (not the LiveCD).

I'd appreciate any help with this.

Question information

English Edit question
Ubuntu grub Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
Ralph Janke (txwikinger) said :

error 15 usually means a file is not found.... could you please list the files in the boot directory (ls -l) here ?

If you need instruction how to do this, please ask for it.


Revision history for this message
rjacobsen (rgjacobsen) said :

These are the files as they are seen through XP, in Ubuntu's boot folder:


Revision history for this message
Ralph Janke (txwikinger) said :

How old is your computer? If I remember right there were some bios' in the past that could not boot from a slave drive or from a partition that was located higher than 4G.

I would be surprised if that would be the case, but it used to be this way.

Revision history for this message
rjacobsen (rgjacobsen) said :


Thanks for helping me with this. My PC is from 2004, so I think this is not the problem. It's an HP Pavillion a462x with upgraded memory, sound and video cards. The slave drive is older, but I guess that may not be the problem also.

Revision history for this message
Ralph Janke (txwikinger) said :

Did you check that all of the files in /boot have a size greater than 0 ?

Revision history for this message
rjacobsen (rgjacobsen) said :

Yes, they do.

Revision history for this message
Best rjacobsen (rgjacobsen) said :


I found the problem, but I am not sure I understood it: I changed the root (hd1,0) line to root (hd0,0), because it came to my mind that when booting from the second HD it might see itself as the first HD. It worked, so I guess the thought was right.