Ubuntu

GRUB not loading Heron after dual-boot install...

Asked by Splunge on 2008-04-26

I have just downloaded the Heron Desktop LiveCD, and installed it as a dual-boot system. Windows XP SP2 is in a primary partition on HD0, and I instructed Heron to take up the remaining space on the HDD (currently registering in GRUB as HD0,4 (ext3) and HD0,5 (Swap)). Installation proceeded as expected, and after install XP still loads from GRUB just fine.
However, neither the normal nor recovery copies of Ubuntu will boot. Normal boot stalls at Grub blanking the screen and displaying a 'Starting up ...' message (which suggests to me that it just plain isn't loading), and the recovery option gets part way through, but (usually) fails somewhere during the PCI/PnP setup.
The PC is a Pentium 4 3.2 GHz on an ASUS P5P800 SE motherboard . 512MB System RAM, ATI Radeon 9600XT video card.
The LiveCD itself gave me some initial problems booting anything until I set the F6 boot option to APCI = OFF, which allowed me to boot the LiveCD and Installer. I have not tested any other settings except noapci, which failed.
I am guessing that the GRUB entries for the Linux Partition needs to be supplied with the boot option, but don't know the correct edit to make to the boot entry in GRUB. I could, however, be entirely wrong.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu grub Edit question
Assignee:
No assignee Edit question
Solved by:
Connor Imes
Solved:
2008-04-26
Last query:
2008-04-26
Last reply:
2008-04-26
Best Connor Imes (rocket2dmn) said : #1

If you want to use the acpi=off and/or noapic option from GRUB during your first boot, at the GRUB menu, select the kernel then press "e" to edit the boot entry. Select the second option (kernel) and press e again, then add "acpi=off noapic" to the end of that line. Escape from there and press "b" to boot the kernel.
Once in the GUI, you can edit your GRUB's menu.lst so it does this all the time automatically:

gksudo gedit /boot/grub/menu.lst

then change your kernel entry to something similar to (but not exactly)

title Ubuntu 8.04, kernel 2.6.24-16-generic
root (hd1,1)
kernel /boot/vmlinuz-2.6.24-16-generic root=UUID=d88c93a3-4af3-4cd0-824e-8d5c172afc47 ro splash noapic acpi=off
initrd /boot/initrd.img-2.6.24-16-generic
quiet
savedefault

Save and close.

Note that your UUID will be different, though your kernel may be the same. I also removed "quiet" from the kernel boot line, but that is just my preference. Also note the added "savedefault". By adding this, these options will be saved even when you get upgraded kernels or GRUB gets updated for some reason during updates at a later time.

Splunge (splunge) said : #2

Thanks, that worked a charm.

Splunge (splunge) said : #3

Thanks Rocket2DMn, that solved my question.