boot problem

Asked by Ronald on 2015-07-28

Have 2 hard drives. 1 has ubuntu 17.04lts and linux mint 17.1. The other i installed linux mint 17.2. During install it said it could not install grub on that drive. After that if i try boot from drive 1 i end up with it saying GRUB and a cusor next to it. When i boot from drive2 it ends up with a cusor in top left corner. Can't type anything have hit re button start

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu grub Edit question
Assignee:
No assignee Edit question
Solved by:
Ronald
Solved:
2015-07-29
Last query:
2015-07-29
Last reply:
2015-07-29

There is no Ubuntu 17.07 yet. That will be released in 2017.. It's only 2015.

In the Ubuntu install, what is the output of:

lsb_release -a

Thanks

Ronald (rbski69) said : #3

Can not get drive 1 or 2 to boot. When i boot #1 the 1gb drive i get the word grub on the top left of screen. When booting from #2 the 100gb drive there is a cuser in top left. No why to go terminal.

Use the Ubuntu install CD to chroot to the installed OS. The guide is called "sticking it to Grub"

You can reinstate Grub to the MBR as well as make it reconfigure itself. Very useful

What version of Ubuntu are you using? As stated before, 17.04 isn't out for 2 years

Manfred Hampl (m-hampl) said : #6

Is this the same system as in question https://answers.launchpad.net/ubuntu/+question/269188 ? I assumed that setting some BIOS flags has already solved the problem?

Do you plug in the disks at the same time, or only one or the other?

Please boot into a live system and provide the output of
sudo fdisk -l

You have to understand that a disk from which you want to boot needs a MBR master boot record installed on it.
If you have installed grub (with its MBR) on disk #1, then remove disk #1 and plug in disk #2 (without MBR on it), the this cannot boot.

Please explain what you try to attempt with your disks, do you want to swap them, or do you want to have them plugged in all the time or,...

Ronald (rbski69) said : #7

I cleared everything off the 100gb drive. Started with a clean drive and put in the partitions. Then did the new install. It is working fine. Grub is showing the other drive and it boots good. So i'm going to call this questen solved. Thanks to all for your help :)