Alternate installer fails to install LILO with RAID1 and LVM over RAID5

Asked by RoboJ1M


I'm trying to install Ubuntu 7.10 using the Alternate x86 CD and it fails near the end of the install with:

Here is what I've posted on the forums: (

I'm making a media server with three 500GB SATA disks in it.
Using Ubuntu 7.10 Alternate x86 CD, it fails when installing the LILO bootloader at the end of the installation. I can skip the LILO installation after it fails but I just end up with GRUB Error 15 (?)

Here is what I'm doing:

Physical drives:



/dev/sda1 - 50MB Bootable RAID (primary, beginning)
/dev/sdb1 - 50MB Bootable RAID (primary, beginning)
/dev/sdc1 - 50MB Bootable RAID (primary, beginning)
/dev/sda2 - ~500GB RAID (primary)
/dev/sdb2 - ~500GB RAID (primary)
/dev/sdc2 - ~500GB RAID (primary)

RAID config:

/dev/md0 - RAID1 (/dev/sda1, /dev/sdb1, /dev/sdc1) - ext2, mount as '/boot'
/dev/md1 - RAID5 (/dev/sda2, /dev/sdb2, /dev/sdc2) - LVM

LVM Config:

/dev/vg0 - LVM VG (/dev/md1)

/dev/vg0/root - 5GB XFS, mount as '/'
/dev/vg0/home - 20GB XFS, mount as '/home'
/dev/vg0/media - ~1TB XFS, mount as '/media'
/dev/vg0/swap - 4GB swap, mount as swap

Everything goes smoothly until just after all the packages have been installed.
It pops up a window asking where to install LILO (because GRUB can't do this, yes?).
This windows has two options:


I select Manual and choose:

/dev/md0 (The bootable 50MB RAID1 array containing /boot)

This fails, and the installation is snafu.


Since then I've also tried:

One primary (/dev/sd<a,b,c>1) and one logical (/dev/sd<a,b,c>5) per drive (failed)
Creating /dev/md0 with 2 active and 1 spare partition (installing as we speak, not holding out much hope)

I'm also having problems clearing down the hard disks so that there is no stuff left over from the last install attempt on it.
It always seems to re-detect old RAID devices or complain about the PC having to be reset before you do anything.

1) Is this install possible?
2) If so, what am I doing wrong?
3) How can I easily restore the hard disks to there initial blank state to make testing easier?



Question information

English Edit question
Ubuntu grub Edit question
No assignee Edit question
Last query:
Last reply:
Revision history for this message
RoboJ1M (jim-neave) said :

OK, I've got an answer to 3) now (mdadm --stop and mdadm --zero-superblock)

I tried installing, letting the install install with no bootloader and following the following guide on fixing GRUB to boot off of a software RAID1 device:

That didn't work, it can't find the file /boot/grub/stage1

Does anybody know why? I'm stuck now, I have no idea what to do.



Revision history for this message
RoboJ1M (jim-neave) said :

I've tried sudo grub-install /dev/sda. That didn't work either...

Revision history for this message
RoboJ1M (jim-neave) said :

I had a go with the exact same install using a Debian Etch DVD.
It gives the exact same LILO error.
Does this suggest that I'm going something wrong, rather than it being a bug?

Revision history for this message
RoboJ1M (jim-neave) said :

Well, I've created a bug report anyway.
At the very least if I'm getting past the partitioner with a bad set of partitions, that's an enhancement in the making.

Revision history for this message
James Neave (roboj1m) said :


Fixed it.

Followed this guide:

4 things were different to what I tried:

1) /dev/sda,b,c1 *not* set to bootable
2) /dev/sda,b,c1 512MB
3) didn't label any of the partitions
4) left 2% of the HDDs as free space (10GB per drive!! 8@)

If I had to guess, I'd say it was 1) that made the difference.
I shall experiment and post the solution.


Can you help with this problem?

Provide an answer of your own, or ask RoboJ1M for more information if necessary.

To post a message you must log in.