Cannot reboot after upgrade from Ubuntu 9.10

Asked by John Truine

I tried to up grade to Unbutu, 10 the old & new are on a partition on my hard drive , my first operating system is Vista & I have had no problems up to now running both systems. When the upgrade was almost finished I checked the box about GRUB I think I should have left it unchecked . and now the boot up will not proceed beyond saying no such device & the a number which I thought was my hard drive number I think I was wrong. What do I do now as the only way to make the computer work is to boot up from my disc drive using my Ubuntu disc.

Question information

English Edit question
Ubuntu grub Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
John Truine (trqu2000) said :

Everything was going fine until the above happened
Hope you can help thanks very much

Revision history for this message
Colin Watson (cjwatson) said :

Thank you for taking the time to report this issue and helping to make Ubuntu better. This isn't yet definite enough to be a bug report, so I'm closing it and converting it to a question in the support tracker, which is better-suited to dealing with this kind of thing. It may become a bug report again later once a volunteer has worked out what the underlying problem is.

Revision history for this message
Best delance (olivier-delance) said :

Could you reinstall Grub from CD:
This usually fixes such issue.

Revision history for this message
John Truine (trqu2000) said :

What I had to do was reload my Vista & then I obtained the UBUNTU 10:10 DVD , I reloaded that from boot up & now everything is fine I am glad to say , I now have two systems working OK . What happened when I tried the update made the computer think that there was no operating system installed but of course there was but it would not boot at all . I am only an amateur as far as computers are concerned so if it does nt work I start from the basics again .