Cannot reboot after upgrade from Ubuntu 9.10

Asked by John Truine on 2010-10-06

I tried to up grade to Unbutu, 10 the old & new are on a partition on my hard drive , my first operating system is Vista & I have had no problems up to now running both systems. When the upgrade was almost finished I checked the box about GRUB I think I should have left it unchecked . and now the boot up will not proceed beyond saying no such device & the a number which I thought was my hard drive number I think I was wrong. What do I do now as the only way to make the computer work is to boot up from my disc drive using my Ubuntu disc.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu grub Edit question
Assignee:
No assignee Edit question
Solved by:
delance
Solved:
2011-02-01
Last query:
2011-02-01
Last reply:
2011-01-26
John Truine (trqu2000) said : #1

Everything was going fine until the above happened
Hope you can help thanks very much

Colin Watson (cjwatson) said : #2

Thank you for taking the time to report this issue and helping to make Ubuntu better. This isn't yet definite enough to be a bug report, so I'm closing it and converting it to a question in the support tracker, which is better-suited to dealing with this kind of thing. It may become a bug report again later once a volunteer has worked out what the underlying problem is.

Best delance (olivier-delance) said : #3

Could you reinstall Grub from CD:
   https://help.ubuntu.com/community/Grub2#Reinstalling%20from%20LiveCD
This usually fixes such issue.

John Truine (trqu2000) said : #4

What I had to do was reload my Vista & then I obtained the UBUNTU 10:10 DVD , I reloaded that from boot up & now everything is fine I am glad to say , I now have two systems working OK . What happened when I tried the update made the computer think that there was no operating system installed but of course there was but it would not boot at all . I am only an amateur as far as computers are concerned so if it does nt work I start from the basics again .