Grub boot up problem [karmic]

Asked by kpk on 2010-03-12

when i try to boot up, my notebook does not enter Grub menu.
Instead i get into a text green that says :-
-------------------------------------------------------------

[ Minimal BASH-like line editing is supported. For
the first word, TAB list possible command
completions. Anywhere else TAB lists the possible
completions of a device/filename. ]

grub>

-------------------------------------------------------------

I tried pressing tab and i get a list of commands.
Tried some of the commands but does not seem to work.
Any advice how do i rescue my system?

Thanks.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu grub Edit question
Assignee:
No assignee Edit question
Last query:
2010-03-12
Last reply:
2010-03-15
Rajinder Sandhu (sandy744) said : #1

type find /boot/grub/stage1
and see what reply it gives it should display your grub loader location something like hd0,0 or 1 or any other digit if you get the reply mail me back on <email address hidden>
if it is not giving same reply then most likely you are having grub-pc installed which has different way.
or
you can boot with recovery mode then select the update grub option then
fix broken packages..that should resolve the issue if everything fails drop to root shell> type startx and keep using your system till the problem is resolved

Rajinder Sandhu (sandy744) said : #2

other alternative is installing grub (in place of grub-pc which is still a buggy program)
when you boot into recovery mode select the last option ie drop to root shell and then type sudo apt-get install grub it will install grub and uninstall grub-pc in the same command.
now type grub-install /dev/sda it will start installing
 sudo update-grub it will updte grub ( press y for the question)
after it has created the grub files then type grub it will show you like this:
grub>
grub> find /boot/grub/stage1
(hd0,x)
grub> root=(hd0,x)
grub> setup (hd0)
grub> quit
reboot the system by typeing sudo reboot and you should see all the booting list

Rajinder Sandhu (sandy744) said : #3

in the reply x should be replace with what ever partion you get in stage 1 reply that is line no. 2 of grub

Rajinder Sandhu (sandy744) said : #4

or reinstall the Ubuntu that is a quick fix

Can you help with this problem?

Provide an answer of your own, or ask kpk for more information if necessary.

To post a message you must log in.