Ubuntu 18.04 grub install fails Asus N56v

Asked by Sahand Vahidnia on 2018-05-01

I am trying to install Ubuntu 18.04 on my Asus N56vv laptop. I tried both USB 3 and USB 2 flash storage drives for installation and both failed. The installation fails at final step (installation of grub).
I have two SSD drives on /dev/sda and /dev/sdb . Disk /dev/sda has a MS Windows 10 with its boot loader. I tried to install Ubuntu on /dev/sdb1 and the boot loader on /dev/sdb (also tried /dev/sdb1) ,failed anyway. I don't want to touch /dev/sda , as it may ruin my Win 10 installation.
I had an Ubuntu 16.04 on /dev/sdb1 previously.
(I will try other things and update this thread.)
Maybe I'm doing something wrong (?)

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: ubiquity 18.04.14 [modified: lib/partman/automatically_partition/question]
ProcVersionSignature: Ubuntu 4.15.0-20.21-generic 4.15.17
Uname: Linux 4.15.0-20-generic x86_64
ApportVersion: 2.20.9-0ubuntu7
Architecture: amd64
CasperVersion: 1.394
CurrentDesktop: ubuntu:GNOME
Date: Tue May 1 18:42:15 2018
InstallCmdLine: BOOT_IMAGE=/casper/vmlinuz file=/cdrom/preseed/ubuntu.seed boot=casper only-ubiquity quiet splash ---
LiveMediaBuild: Ubuntu 18.04 LTS "Bionic Beaver" - Release amd64 (20180426)
ProcEnviron:
 LANGUAGE=en_US.UTF-8
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 LC_NUMERIC=C.UTF-8
SourcePackage: grub-installer
UpgradeStatus: No upgrade log present (probably fresh install)

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu grub-installer Edit question
Assignee:
No assignee Edit question
Solved by:
Sahand Vahidnia
Solved:
2018-05-17
Last query:
2018-05-17
Last reply:
2018-05-01
Sahand Vahidnia (sohanad1990) said : #1

I believe this was my mistake and I failed to try installing without EFI. However it still boggles my mind and I don't get why it fails?

If you boot to live CD, you can chroot to the installed OS and install GRUB manually to /dev/sdbv

You can then set the BIOS to boot to the Ubuntu drive and GRUB will load

Sahand Vahidnia (sohanad1990) said : #3

My own solution to this was booting the installation media without EFI.
However, the answer from actionparsnip (andrew-woodhead666) also seems to be correct, but I didn't try it.
Thanks.