Ubuntu installation on Lenovo Z50-75 15,6" failed

Asked by Simo Makkonen on 2015-04-04

Just purchased a new Lenovo Z50-75 laptop with ADM10 processor and Win 8.1 64bits OS.
Did the Ubuntu 14.04 desktop installation from USB (using Unetbootin under Win). The installation went smoothly, but ... wifi didn't work and grup-loader failed to open Win.
Luckily I was able to restart Win OS from the bios settings.
Is this a "mission impossible" or should I try another time - and how? I was relying on that Lenovo gives support to Linux/ubuntu and that the mutual coop works. Running Ubuntu in a more effecient machine was the only reason for me to by this Lenovo and this was the first time for me to fail with the installation.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu grub-installer Edit question
Assignee:
No assignee Edit question
Solved by:
Simo Makkonen
Solved:
2015-04-06
Last query:
2015-04-06
Last reply:
2015-04-05

What WiFi chip does the system have?
Have you used a wired connection to get fully updated. This can help

Simo Makkonen (simo-makkonen) said : #2

Hi,
I tried to reinstall, but with the same result. Internet cable was connected.

The machine has the following OS/ processors/drivers:

- OS Name Microsoft Windows 8.1, Version 6.3.9600 Build 9600 x64
- BIOS Version/Date LENOVO A4CN32WW (V 2.01), 9/11/2014, Bios mode UEFI
- System SKU LENOVO_MT_80EC0_BU_idea_FM_Lenovo Z50-75

- Processor: AMD A10-7300 Radeon R6, 10 Compute Cores 4C+6G, 1900 Mhz, 4 Core(s), 4 Logical Processor(s),
- Network adapter: Name [00000000] Realtek PCIe GBE Family Controller, Type Ethernet 802.3, Product Type Realtek PCIe GBE Family Controller, PNP Device ID PCI\VEN_10EC&DEV_8168&SUBSYS_381417AA&REV_10\01000000684CE00000, Driver c:\windows\system32\drivers\rt630x64.sys (8.24.1218.2013, 820.21 KB (839,896 bytes), 12/22/2014 6:01 AM)

HDD is Samsung MZYTE256HMHP-000L2 , SSD-type
- the (factory) partition includes:
   Recovery (1000 MbB
   EFI system (260 MB)
   OEM (1000 MB)
  Recovery (13,43 GB)
  D: Lenovo primary (25,0 GB NTFS)
  C: Windows8_OS ( now 90,29 GB NTFS)
  unallocated (107,42 GB)

I wonder where ubuntu did the second installation because the partition where it should have gone shows unallocated. And still I can start ubuntu!!? (I did clean up the first Ubuntu installation partitions.)
When starting the installation from my USB the sw recognized two partitins. No idea which they were. For preparing the USB installation stick I used the latest Ubuntu 14.04 LTS x64 downloadable image file and Startup create disk sw on my old Ubuntu machine.

If you check in disk manager do you see it as unknown.

Windows is dumb and will not show that the file system is Linux based, even though it can set the disk type in fdisk.

With a disk setup as you have you will need to make an extended partition of the space to then make logical partitions to install Ubuntu into.

Simo Makkonen (simo-makkonen) said : #4

Thanks. I refreshed it in Win8 Disk Management so the two partitions became visible and I deleted them. After that I had again one unappointed partition which I reset (label E) and changed into RAW.
Before I try the installation (manually is probably the best way of doing it) I'll update my bios from Lenovo and Win8 (incl. drivers) from MS.
Have never before been dealing with UEFI, which seems to be the booting stm in this machine. Should the start-settings be changed before installation or do I need a different inst. settings in USB?

Simo Makkonen (simo-makkonen) said : #5

Hi Andrew
and thank you very much of your help. The installation was fine and everything is working now. My first mistake was not to use the "Something else" option for the installation. So using the "tradional" method was good. Then, of coarse I had to disable the secure boot from bios.
Thanks one more time.

br Simo

Simo Makkonen (simo-makkonen) said : #6

Let's close this.