Ubuntu 22.04 python3-grpcio causes some apps to use 100% of the CPU

Asked by Gustavo Iñiguez Goya


After the latest Ubuntu release 22.04, we've realized that the package python3-grpcio 1.30.2-3build6 causes [0] opensnitch to use 100% of the CPU [1].

This problem has never occurred before, it has worked fine on previous versions, even with python3-grpcio 1.30.2-3 from 21.04.

If I install grpcio via pip, it works fine, with latest version 1.44.x (>= 1.16.x and <= 1.44.0).

I've tried to debug it (GRPC_VERBOSITY=debug, GRPC_TRACE=tcp,http,api...), but it prints nothing. Analyzing it with strace shows some activity, but nothing like printing continuously logs like it would be stucked on some operation.

On a normal execution grpc.server.start() is executed and the app continues with other tasks, but on this case it never passes start().

In fact, the basic example from the grpcio website doesn't work either, it also consumes 100% of the CPU: http://grpc.io/docs/languages/python/basics/

I'm running out of ideas on how to debug this problem. Can someone help to identify the reason of this problem?

[0] - https://github.com/evilsocket/opensnitch/
[1] - https://github.com/evilsocket/opensnitch/issues/647

Question information

English Edit question
Ubuntu grpc Edit question
No assignee Edit question
Last query:
Last reply:
Revision history for this message
Gustavo Iñiguez Goya (gooffy1) said (last edit ):

lsb_release -rd:

  Description: Ubuntu Jammy Jellyfish (development branch) (from the .iso)
  Release: 22.04

apt-cache policy python3-grpcio:

  Candidate: 1.30.2-3build6
  Version table:
     1.30.2-3build6 500

Revision history for this message
Manfred Hampl (m-hampl) said :

If lsb_release still tells " Description: Ubuntu Jammy Jellyfish (development branch)" then you do not have the most up-to-date version of Ubuntu 22.04.

I suggest that you do full updates and try again.

Revision history for this message
Gustavo Iñiguez Goya (gooffy1) said :

Hi Manfred! I did a full upgrade, but there's no new python3-grpcio version.

Latest version is 1.30.2-3build6 :


Anyway, the problem still occurs with the system fully updated.

lsb_release -rd:

  Ubuntu 22.04 LTS

Can you help with this problem?

Provide an answer of your own, or ask Gustavo Iñiguez Goya for more information if necessary.

To post a message you must log in.