Running grass6.4 under xenial

Asked by Wayne on 2016-08-16

Is my only option for running grass6.4 under Ubuntu 16.04 LTS xenial to try and compile GRASS and all dependent packages from source code? I've looked in the "unstable" repository and not found GRASS 6.xx.

There is quite a difference between GRASS6 and GRASS7 which is causing issues with my application software that uses GRASS.

Thanks in advance.

Wayne

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu grass Edit question
Assignee:
No assignee Edit question
Last query:
2016-08-16
Last reply:
2016-08-17

I suggest you report a bug. If the bug and security fixes are significant then the package will be updated sooner rather than later. In LTS releases it is rare to see package updates as stability is champion over new package versions

Manfred Hampl (m-hampl) said : #2

I do not think that it will be easy to install a 6.4 package on xenial.

If I look at the latest 6.4 version (6.4.4-1build4 for wily), I see dependencies on libmysqlclient18 and libnetcdf7 which do not exist on xenial (replaced by libmysqlclient20 and libnetcdf11).

What prevents changing the application that you are using to allow it also work with version 7.* ?

Can you help with this problem?

Provide an answer of your own, or ask Wayne for more information if necessary.

To post a message you must log in.