Manual unmounting of busy hard drive volume

Asked by indemo on 2009-07-11

Hi,
I have just wiped windows and installed Suse and Ubuntu on my laptop. As a newbie I kind of prefer Ubuntu. The problem I have is that Ubuntu cannot install its latest updates due to lack of space on my home volume. (/dev/sda4)
I need to change the size of this volume and I am using Gparted but the Umount option is disabled.
I tried to unmount the subsequent volume /sda5 mounted within /sda4 but it would not allow me saying:

"The partition could not be unmounted from the following mount points:
/
Most likely other partitions are also mounted on these mount points. You are advised to unmount them manually.

I tried to do this manually with sudo umount /dev/sda4 command but still gives me the message that the device is busy.

How can I resolve this? Would appreciate your help/suggestions on this.
Thanks.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gparted Edit question
Assignee:
No assignee Edit question
Solved by:
indemo
Solved:
Last query:
Last reply:

Please tell...

Have you booted your pc using the Ubuntu live cd to resize your partitions...?

I mean your pc must start entirely from the Ubuntu live cd insterted into the cdrom drive, you need to start your pc in this way to resize partitions.

Thank you

indemo (tiberiukiss) said : #2

Hi Marco,

Thanks for your reply.
Indeed, I installed the Ubuntu from an iso file I downloaded from Ubuntu site which I then burnt on a dvd.
The installation process asked if I want to install the os on the entire hard drive or side by side with the other one I had (Suse). I selected side by side option and it seems it put it onto a very small partition with only 190Mb free space left.
Do I have to re-install the OS and set the size of the Ubuntu partition at the installation step? Is there a way to do this with the Gparted application or some other way without re-installing?

Thank you!

Yes i think you can do it with the Ubuntu live cd lowering the size of the ext3 Suse partition and increasing the Ubuntu partition.

Please boot your pc entirely from Ubuntu 9.04 desktop live cd menu, then try gparted from the menu:

System → Administration → Partition Editor

to resize partitions.

Hope this helps

indemo (tiberiukiss) said : #4

I just rebooted with the live CD. For some reason to Gparted wouldn't allow the increase of that partition. I decreased the size of the large available block next to it and then I tried again. Still without success so I decided to re-install Ubuntu over the whole drive. I hope this will put me back on track where I started, installing the Ubuntu updates (100 + Mb).

Thank you Marco for your help. Much appreciated!

paolode (paolo-debortoli) said : #5

a bit strange behaviour. I am using ubuntu 12.04 on hp pavilion laptop with cinnamon, nemo, nautilus (but he behaviour is showed in other cases). I have external usb hdd and a crypted partition (luks format) on internal hd. when I unmount external hdds it doesn't show any message like 'it is now safe to remove drive' and sometimes says 'failed to unmount'. when I unmount the crypted partition it says always 'failed to unmount'. however hdds and crypted partition are always unmounted. it seems that the system fails to check and close applications and processes related to hdds and partition. I have another normal xfs backup partition on internal hd, which doesn't show such problems in unmounting.