External SSD I/O Error creating partition table

Asked by AJ on 2016-03-18

Please excuse my formatting. First post. I will include what happened for reference. Thank you in advance for reading all of this.

Story: So my SSD sent me into a boot loop when Windows 8 was upgrading to 8.1. It wouldn't even go into BIOS. I took the harddrive out and put hooked it up to an older laptop with an Ubuntu Live disk. I tried to format the disk with the Disks GUI. There was an error and it failed. I used DISKPART on windows to attempt to format the drive. I was able to 'clean' the disk. The disk was listed, but there were no volumes and I couldnt create any partitions.

Current Issue: Now I'm getting an I/O Error from Gparted. It also says Label Not Recognized, under Properties. The whole file system is unallocated and it says there is no partition table. I get the I/O error when trying to create a partition table. I'm stuck at this point. I understand what I did, but Its been a long 6 hours of learning. The drive is 100% fine. Its a 5 month old SSD and I completed some health tests. It says its fine.

What I want to do: I don't care about anything that may have been on the drive. I just want to install Windows so I can play my games again. What can I do to add a partition table manually? The drive also does not show up in the File Browser.

I ran these commands while trying to follow another thread. The thread fell short though. FDisk -l -u shows nothing at all.

ubuntu@ubuntu:~$ sudo parted /dev/sdd unit s print
Error: /dev/sdd: unrecognised disk label
ubuntu@ubuntu:~$ sudo fdisk -l -u /dev/sdd
ubuntu@ubuntu:~$ sudo fdisk -l -u /dev/sdd
ubuntu@ubuntu:~$ ^C

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gparted Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
2016-03-19
Last query:
2016-03-19
Last reply:
2016-03-18
AJ (andy-j-theriault) said : #1

#[ ubuntu@ubuntu:~$ sudo fdisk /dev/sdd
fdisk: unable to read /dev/sdd: Input/output error
]

You can use dd in live CD / USB to write zeros from the start of the drive to the end.

AJ (andy-j-theriault) said : #3

Thank you. I am a complete noob though. I've never used dd, but I've been seeing it a lot in the past day, so I understand its powerful. I will have the drive plugged in as an external. What exactly is the sequence of commands I have to use?

dd if--(??) of=(??)

What is the output of:

sudo fdisk -l

Thanks

AJ (andy-j-theriault) said : #6

I was able to format the drive and install Ubuntu after disconnecting the hard drive. It booted to the bios after a few tries, then I was able to disable everything by my DVD drive in the boot options. Changing the order didn't work because it kept resetting, even after saving. Disabling the options worked though.

I was a few hours from sending the whole thing back to Samsung