Trying to use GParted to partition drives

Asked by Rick Larson on 2012-09-06

First time Ubuntu user, new to Linux, fairly knowledgeable in Windows. I'm trying to set up a home server using Ubuntu Desktop as my needs are minimal. Afetr installing Ubuntu 12.04, the instructions (http://lifehacker.com/5919558/turn-an-old-computer-into-a-networked-backup-streaming-or-torrenting-machine-with-ubuntu) told me to open terminal window (ALT-F2?) , enter sudo apt-get install gparted pysdm , click on dash and search for GParted. GParted is not there, where is it? Nothing really seemed to happen when I opened the terminal and entered the command line info. Not sure what happened, if anything, maybe GParted was not initiated? I would assume thqat GParted would open up in a window and I should be able to format and partition drives so they can be used on a home network with mixed (WIN/Linux) operating systems.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gparted Edit question
Assignee:
No assignee Edit question
Solved by:
Rick Larson
Solved:
2012-09-06
Last query:
2012-09-06
Last reply:
2012-09-06

If the partitions are going to be accessed over a LAN, the format doesn't matter. If you press CTRL+ALT+T you can then run:

sudo apt-get update
sudo apt-get upgrade
sudo apt-get dist-upgrade
sudo apt-get install gparted samba
sudo smbpasswd -a $USER

(You don't need to change the password in any way). You can now run:

gksudo gedit /etc/samba/smb.conf

add these lines (I assume your username is 'foo'):

[Shared data]
path = /home/foo
comment = Shared stuff
browsable = yes
read only = no
writable = yes
valid users = foo
invalid users = root bin daemon nobody

Save the new file, close gedit and run:

sudo service smbd stop
sudo service smbd start

You now have a Windows share and you can authenticate as foo with the password you set earlier.

Rick Larson (rwlrsn) said : #2

Entered: valid users=foo (I am foo); returned "valid: command not found" used validusers, seemed to work
Entered: invalid users=root bin daemon nobody; returned "invalid: command not found"
Entered: invalidusers=root bin daemon nobody; returned "No command 'bin' found, did you men:..."
not sure how to save, enteed gedit save command, window pooped up, save was an option, selected save and closed window

how can I verify /etc/samba/smb.conf has the configuration data needed?
how do I review and save the file once updated?

Sorry if I am being too literal, but as mentioned before, this is my first venture into Linux

Your username isn't foo. If you run:

whoami

What does it say?

Rick Larson (rwlrsn) said : #4

sorry for the confusion, I used rick instead of foo and whoami returns rick

N1ck 7h0m4d4k15 (nicktux) said : #5

Hello ,

you can see the configuration file with bellow command in terminal

+++++++++++++++++++++++++++++++
cat /etc/samba/smb.conf
+++++++++++++++++++++++++++++++

See if your changes have been saved correctly.

Above command will print the contents of smb.conf in stdout .

Thanks

Rick Larson (rwlrsn) said : #6

It worked, thanks!