Cannot use hidden flag from gparted - Ubuntu 12.04

Asked by N1ck 7h0m4d4k15 on 2012-06-06

Hello and forgive me for my bad English.
I discovered a problem lately when i wanted to hide some partitions from nautilus devices list.
I used gparted hidden flag option but i saw that i was unable to mark the flag. I don't know the reason cause no error message appeared . It just not mark the box.
I have already tried this from Ubuntu 11.10 , Bodhi linux 2.0.0(Alpha) , Lubuntu 11.10 , Ubuntu 10.04 either regular installs or live CD's .
My regular installation is triple boot with Ubuntu 12.04 , Lubuntu 12.04 and Bodhi Linux 2.0.0(Alpha - Ubuntu 12.04 based)

Some extra info might be that i tried this to another machine ( desktop ) and i was able to hide ntfs partitions but again Unable to hide any linux (filesystem) partition.

Please be patient and keep in mind that i am not Ubuntu geek.

I will give you some info that might help ..

cat /etc/lsb-release && uname -r


apt-cache policy gparted

  Installed: 0.11.0-2
  Candidate: 0.11.0-2
  Version table:
 *** 0.11.0-2 0

sudo fdisk -l

Disk /dev/sda: 320.1 GB, 320072933376 bytes
255 heads, 63 sectors/track, 38913 cylinders, total 625142448 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disk identifier: 0x0001f627

   Device Boot Start End Blocks Id System
/dev/sda1 4094 287031295 143513601 5 Extended
Partition 1 does not start on physical sector boundary.
/dev/sda2 613308416 625141759 5916672 82 Linux swap / Solaris
/dev/sda3 287031296 489975807 101472256 83 Linux
/dev/sda4 489975808 613308415 61666304 83 Linux
/dev/sda5 4096 206665727 103330816 83 Linux
/dev/sda6 206667776 210929663 2130944 83 Linux
/dev/sda7 210931712 287031295 38049792 83 Linux

Partition table entries are not in disk order

sudo parted -l

Model: ATA WDC WD3200BPVT-2 (scsi)
Disk /dev/sda: 320GB
Sector size (logical/physical): 512B/4096B
Partition Table: msdos

Number Start End Size Type File system Flags
 1 2096kB 147GB 147GB extended
 5 2097kB 106GB 106GB logical ext4
 6 106GB 108GB 2182MB logical ext4
 7 108GB 147GB 39.0GB logical ext4
 3 147GB 251GB 104GB primary ext4
 4 251GB 314GB 63.1GB primary ext4
 2 314GB 320GB 6059MB primary linux-swap(v1)

Question information

English Edit question
Ubuntu gparted Edit question
No assignee Edit question
Solved by:
Filippos Kolyvas
Last query:
Last reply:
Revision history for this message
Wyatt Smith (wyatt-smith) said :

I would suggest a different approach to hide partitions from Nautilus list.

There are typically two locations used for mounting partitions (/mnt and /media). Anything mounted in /media will show up in the nautilus list, while partitions mounted /mnt will not.

I would suggest putting an entry in /etc/fstab for the devices you want to hide. You should have these partitions mount to a sub-folder with /mnt. Also consider using the noauto option to prevent these partitions from automounting on boot.

Hope this helps

Revision history for this message
N1ck 7h0m4d4k15 (nicktux) said :

Hi @Wyatt Smith

Thanks for the suggestion , I already knew this option from fstab . (sorry that i didn't mentioned)
My problem is why the hidden flag option not work from gparted ? specific on Linux partitions.

Is this option (flag) works for you ? Can you use it on Linux partitions ?

Revision history for this message
Wyatt Smith (wyatt-smith) said :

Looking back, I realize that I didn't really answer your question. The hidden flag does not work for me on linux partitions. I believe these flags are used by windows rather than linux. For example, linux does not need the boot flag enabled in order to boot. I checked the gparted manual and it looks like these flags are for msdos partition tables. The following is a limited quoted from the manual:

A description of flags in an msdos partition table follows:

    Hidden is used by some commercial operating systems. The hidden flag makes the partition invisible to the operating system.

Revision history for this message
N1ck 7h0m4d4k15 (nicktux) said :

Hi , @Wyatt Smith
thanks for your answer once again .
Maybe you have right about Linux file-systems , that cannot use hidden flag .
However allow me to wait a little more time and search it (little more) before i close my question , cause some users they have this ... i don't know how to describe it... ability ? use this flag on Ubuntu and i don't know why me (or you) we can't.

Revision history for this message
N1ck 7h0m4d4k15 (nicktux) said :

Anyone has a clue about this ? My search was unsuccessful.

Can you post here if this flag works for you ?
@Wyatt Smith said "The hidden flag does not work for me on linux partitions"
what do you say ?

Revision history for this message
Best Filippos Kolyvas (fkol-k4) said :

I am using two hard disks of the same make and model on my system, and the only differences betweeen them are:
1. The size, and
2. That one is formatted using the traditional MS-DOS Partition table (Default selection in Gparted) and the other is foratted using a GUID Partition Table (GPT).

After some testing, i came to the conclusion that setting a hidden flag on an ext4 partition is possible only on the disk that uses the GUID Partition Table.
Maybe it is a restriction that concerns the gparted utility, the ext4 filesystem, or even the MS-DOS Partition table.

Revision history for this message
N1ck 7h0m4d4k15 (nicktux) said :

Thanks Filippos Kolyvas, that solved my question.