Gparted, NTFS resize, partition lost

Asked by S.Rey on 2011-08-24

I've tried to resize (shrink) an NTFS partition using Gparted (Ubuntu 11.04).
It has failed and as a result I have lost all the data.

Is there anything that can be done to recover the data in the partition?
It seems that it has shrink device size but not volume size.

Here is some information.

sudo ntfsresize -P -i -f -v /dev/sda5
ntfsresize v2.0.0 (libntfs 10:0:0)
Device name : /dev/sda5
NTFS volume version: 3.1
Cluster size : 4096 bytes
Current volume size: 63523799552 bytes (63524 MB)
Current device size: 50815747584 bytes (50816 MB)
ERROR: Current NTFS volume size is bigger than the device size!
Corrupt partition table or incorrect device partitioning?

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu gparted Edit question
Assignee:
No assignee Edit question
Last query:
2011-08-24
Last reply:
2011-08-24

Use your backups

S.Rey (s.rey) said : #2

Oh, thank you, this helps a lot. I wouldn't be able to think about it myself...

Anyway, in case anybody finds this, looking for a real solution to the same problem, please follow this tutorial to recover the partition. This is caused by a bug in parted.
http://gparted-forum.surf4.info/viewtopic.php?id=13937

Its the logical first step, isn't it. If your data is important you should have a regular backup, especially if you are resizing partitions which is very risky.

S.Rey (s.rey) said : #4

You are true, but it's so logical that I wouldn't need to ask if that was a viable alternative.
I do have a backup, just not as recent as I would like. So I kept that as a last resource, in case there was no other way to solve the issue.
I've never had a problem with gparted until now, so I didn't feel the need of making a new backup before using it, (which is obviously my fault).
So I came here looking for a way to repair the existing data, wondering if this was caused by some known bug, which fortunately has proven to be true.

Thanks anyway. Problem solved.

Can you help with this problem?

Provide an answer of your own, or ask S.Rey for more information if necessary.

To post a message you must log in.