How to connect to google talk

Asked by Onkar Shinde on 2007-03-01

Can anyone give detailed instructions for connecting to Google Talk service using gossip-telepathy?
Also is it possible to use VoIP of Google Talk when using gossip-telepathy?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gossip-telepathy Edit question
Assignee:
No assignee Edit question
Solved by:
Onkar Shinde
Solved:
2007-03-02
Last query:
2007-03-02
Last reply:
2007-03-01
Onkar Shinde (onkarshinde) said : #2

I have read that page already and it doesn't provide any gossip-telepathy specific information. Also I tried configuring gossip-telepathy form my previous knowledge of configuring gaim but my account was not connecting.

Matt Thompson (mattthompson) said : #3

Open the accounts dialog (Edit>Account), and in there fill in all the information you know, you can set the Account Name as anything you want.

Set the server to talk.google.com and make sure that the port is 5222.

That should work, try it with and without the SSL box checked, I can't remember whether it needs that or not.

RE VoIP and Google talk, as far as I know (though I could be wrong), only the official (and Windows only) Google talk client can use the VoIP part.

Hope I helped,

Matt

williamts99 (williamts99) said : #4

You are correct that there is not gossip-telepathy specific information on that page, but you should be able to get the information that you need to connect using that as a guide, usually the only differences will be where exactly you enter the information. http://www.google.com/support/talk/bin/answer.py?answer=24073 gives instructions for Gaim but you can get the settings from there and use them in gossip-telepathy. As far as using the VoIP of Google talk, it looks like you will be able to do that in the future.

Also, if you want specific information as to gossip-telepathy and google talk configuration, I searched google for:

gossip-telepathy google talk

And the first two links should help you out a lot, has very specific information.

Best Regards,
Williamts99

Best Onkar Shinde (onkarshinde) said : #5

Thanks for all your replies.

The solution (as found at http://www.nabble.com/Cannot-connect-to-google-talk-with-Telepathy-t3191769.html) :
1. The port needs to be set as 5223. This is different from default port (5222) which works in Gaim.
2. SSL checkbox needs to be checked. This is different from Gaim. Gaim uses TLS.

Although initially even these settings didn't work, I realized that I may be hit by network-manager related bug #82335 and I was right. After I stopped network-manager and restarted gossip it worked properly. I will document it somewhere on wiki.