Google Earth is very slow

Asked by Sava Pavlovic on 2010-01-30

Dear experts,
I have down loaded GE accor4ding to your instraction on the following way:

sava@sava-laptop:~$ cd Downloads
sava@sava-laptop:~/Downloads$ chmod +x GoogleEarthLinux5.0.bin
sava@sava-laptop:~/Downloads$ ./GoogleEarthLinux5.0.bin
Verifying archive integrity... All good.
Uncompressing Google Earth for GNU/Linux 5.0.11733.9347..............................................................
loki_setup: Suspect size value for option option

loki_setup: Suspect size value for option option

Installing mimetypes...
Installing desktop menu entries...
Installing desktop icon...
do_wait: drmWaitVBlank returned -1, IRQs don't seem to be working correctly.
Try adjusting the vblank_mode configuration parameter.
It runs, but very, very slow. I dont know how to procede further? , or instalation procedure was not OK.
I am using Ubuntu 9.10, and integrated ATI card, so the video drivers are loaded together from Linux base. I dont understand, the suggestion for adjusting "vblank", if it can help?
I am waiting for clear explanation and proposal.
Thank you in advance
Sava Pavlovic

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu googleearth-package Edit question
Assignee:
No assignee Edit question
Solved by:
Federico Vera
Solved:
2010-02-01
Last query:
2010-02-01
Last reply:
2010-01-30
Best Federico Vera (fedevera) said : #1

Hi! If you are using a NON-CRT display you should not worry about the vblank thingy.
It seems you might be having a little controller issue here. First try checking if there's a proprietary (the free one still needs a lot of work) controller available for your video card "System->Administration->Hardware drivers", if there's one available (fglrx) install it, restart the pc and open google earth again.
Other possible alternative is that compiz (desktop effects) is misbehaving, so try deactivating it "Right click on the desktop->Change desktop background->visual effects->None".

Hope it helps!

Sava Pavlovic (p-sava) said : #2

Dear Mr. Federico,
Thank you for your proposal, but it doesn't help. I have LCD display. No new uninstalled drivers on ("Hardware Drivers") . Is (fglrx) the name of the driver? Deactivation on background is without effect.
Thank you once again for your good will.
Regards
Sava Pavlovic

Federico Vera (fedevera) said : #3

Hi again! too bad that didn't work (usually does). Lets try a different approach, could you please copy the results of the following commands?
(this must be done from a terminal "Applications-> Accessories->Terminal"):

glxinfo | grep "direct rendering"
(this one should just show yes or no)

if the answer is yes, then run google earth from the terminal the command should be 'googleearth' (when you do this some error messages should appear in the terminal), close it (google earth, not the terminal) and copy the resulting messages in here.

PS: Yes fglrx is the name of the proprietary driver of ATI.

Sava Pavlovic (p-sava) said : #4

Dear Mr. Federico,
It is slightly better, but I will wait for my son that comes tomorrow. He have better understanding of your solution.
In the meantime I have downloaded new ATI driver "Catalyst 92 Linux", and he will help me with this installation as well.
You will be informed at the end of course.
Thank you once again
Sava Pavlovic

Sava Pavlovic (p-sava) said : #5

Dear Mr. Federico,
Fiiinalyyyy OK. Because of unkown reasons command "sudo" start to work and everything is working normal. Even without instalation of new ATI driver.

Besides that. in Manuel for Driver are requested

glibc version 2.2 or 2.3 and
 XOrg 7.5

I can't discover if it is allready installed in my mashine. I have downloaded it from the net, but I am affraid to instal it. I have Ubuntu 9.10.
Thank you once again.
Greetings from Belgrade Serbia
Sava Pavlovic

Sava Pavlovic (p-sava) said : #6

Thanks Federico Vera, that solved my question.