Google earth doesn't show maps

Asked by Paulo Nobre on 2013-01-13

Hi, my instalation of google earth doesn't show any maps, it shows all the layers and functionalities but without globe or map terrain. Futhermore I can't start session in Maps Engine, it gives a message 'Unknown protocol specified'.

I've downloaded the debian package from google earth web site, and installed it with dpkg with no errors. The aplication starts normaly but without the globe.
I've searched for answers but couldn't find any related issue.

Could anyone help?
Regards Paulo

system - Kubuntu 12.10

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu googleearth-package Edit question
Assignee:
No assignee Edit question
Solved by:
N1ck 7h0m4d4k15
Solved:
2013-01-14
Last query:
2013-01-14
Last reply:
2013-01-14

Can you give the output of:

lsb_release -a; uname -a; dpkg -l | grep -i earth

Thanks

Paulo Nobre (paulo-a-g-nobre) said : #2

LSB Version: core-2.0-ia32:core-2.0-noarch:core-3.0-ia32:core-3.0-noarch:core-3.1-ia32:core-3.1-noarch:core-3.2-ia32:core-3.2-noarch:core-4.0-ia32:core-4.0-noarch
Distributor ID: Ubuntu
Description: Ubuntu 12.10
Release: 12.10
Codename: quantal
Linux pn-f01k 3.5.0-21-generic #32-Ubuntu SMP Tue Dec 11 18:52:46 UTC 2012 i686 i686 i686 GNU/Linux
ii google-earth-stable 7.0.2.8415-r0 i386 Explore, search and discover the planet

How did you install the application?

Best N1ck 7h0m4d4k15 (nicktux) said : #4

Download and install the 6th version of google earth please.

First uninstall this version and then download from here
http://www.ubuntuupdates.org/package/google_earth/stable/main/base/google-earth-stable

the 6th stable version and install it.

Thanks

Paulo Nobre (paulo-a-g-nobre) said : #5

Ok, Thank's 'actionparsnip' and 'NikTh' for your replies.
I've been testing diferent configurations and finally the solution proposed by 'NikTh'.

'actionparsnip', I downloaded the latest .deb file from google and instaled it with 'dpkg -i <path_to_file_filename.deb>', and everything seemed to be okay in the instalation. The aplication started normaly, the only problem was the absence of the globe and the earth images.

Finaly I've uninstalled the latest version and installed the version '6.0.3.2197' found in the location proposed by 'NikTh'.
I also downloaded the .deb file and instaled it with 'dpkg -i <path_to_file_filename.deb>', and finally the aplication is working well with all the functionalities 'and the maps' :).

It seems that there is a problem with the latests versions in my machine. But the version 6.0.3.2197 is working fine and it suits me well.

Thank you all for your atention, you've been very helpfull.

Best Regards
Paulo

Paulo Nobre (paulo-a-g-nobre) said : #6

Thanks NikTh, that solved my question.