Google Earth 6.1.0.5001 on Ubuntu 10.04 Lucid

Asked by jcglt on 2012-01-01

I ran without any problem Google Earth 5 on my laptop (Ubuntu 10.04 Lucid with kernel 3.0).
I upgraded yesterday to 6.1.0.5001 from the official download site and installed the 32bit .deb version.

When I start it I get a message saying that it will start in OpenGL, which works more slowly than DirectX mode. It then asks me the question : Would you like to shift to DirectX mode ? No or Yes.

I type No and nothing happens.

I type Yes and usually nothing happens at first attempt, then doing again the whole procedure several times it Google Earth starts and works well.

I had a look inside the /home/my_directory/.googleearth/crashlogs/ and here is a copy of one of the crashlogs found there :

<<<
Major Version 6
Minor Version 1
Build Number 0000
Build Date Oct 17 2011
Build Time 04:05:20
OS Type 3
OS Major Version 3
OS Minor Version 0
OS Build Version 0
OS Patch Version 0
Crash Signal 11
Crash Time 1325279770
Up Time 147,343

Stacktrace from glibc:
./libgoogleearth_free.so(+0xbcd53)[0x538d53]
./libgoogleearth_free.so(+0xbced3)[0x538ed3]
[0xe18400]
./libQtGui.so.4(_ZN14QWidgetPrivate11show_helperEv+0x61)[0x11785f1]
./libQtGui.so.4(_ZN7QWidget10setVisibleEb+0x1db)[0x1178a2b]
./libQtGui.so.4(_ZN14QWidgetPrivate12showChildrenEb+0x170)[0x1178560]
./libQtGui.so.4(_ZN14QWidgetPrivate11show_helperEv+0x61)[0x11785f1]
./libQtGui.so.4(_ZN7QWidget10setVisibleEb+0x1db)[0x1178a2b]
./libQtGui.so.4(_ZN7QWidget10showNormalEv+0x5c)[0x116616c]
./libgoogleearth_free.so(_ZN10MainWindow18readScreensizeInfoEv+0xd3f)[0x50201f]
./libgoogleearth_free.so(_ZN5earth6client11Application12SetupMainWinENS0_3Kvw7ProductEb+0x31c)[0x53f9bc]
./libgoogleearth_free.so(_ZN5earth6client11Application3runEv+0x6d6)[0x542f86]
./libgoogleearth_free.so(+0xbb80b)[0x53780b]
./libgoogleearth_free.so(earthmain+0x247)[0x538987]
./googleearth-bin[0x804876b]
/lib/tls/i686/cmov/libc.so.6(__libc_start_main+0xe6)[0x7740bd6]
./googleearth-bin[0x80486b1]
>>>

Does any member have an idea about what I missed ?
Many thanks in forehand and a Happy New Year to all.
jcglt

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu googleearth-package Edit question
Assignee:
No assignee Edit question
Solved by:
jcglt
Solved:
2012-01-01
Last query:
2012-01-01
Last reply:
2012-01-01
marcus aurelius (adbiz) said : #1

first of all, directx is only for windoze.

secondly, what exactly is your question?

marcus aurelius (adbiz) said : #2

i tried google earth on 10.04. it's really crappy. i went back to version 5.

jcglt (jcjglt) said : #3

Thanks to all.

I understood that DirectX is a Windows only application but then I wonder why a Google Earth 6 installed on a Linux system allways asks, when being started if I want it run under DirectX !

I uninstalled totally this 6. version with Synaptic then downloaded GoogleEarthLinux.bin and installed it again using this method :
<<<
Install Google Earth
Download and save the Google Earth installer for Linux.
The file you downloaded should be called GoogleEarthLinux.bin. Find this file, right mouse click on it and select Open with Other Application.
Click to expand the Use a custom command section of the Open With dialog. Type sh, and click Open.
>>>

It seems to work better even if it still asks me if I would like to start it with DirectX to which I answer NO but at least it starts.
I consider this is solved, even if not totally satisfactorily.