Google Earth problems in 10.10

Asked by kwardill on 2011-03-08

Hi,
I just installed Google Earth (Ubuntu 10.10, Earth 6.0.1.2032). After installation, it would not start from the menu option. After browsing through previous related questions, and trying almost all the suggestions (really), I found that Eliah Kagans reply to Question 143643 - to install the lsb-core package - allows me to start Google Earth from its menu option - so far so good.
However, the displayed map has serious 'radial' line distortions on it, and the edges of the map are not square but appear as a ragged map edge against a gray and black background. The only way I can describe the 'radial' lines are like several narrow pie-slices, maybe 5 or 10° wide. Some appear to be a distorted section of the map, some are just black or white. As I move the map, they change, apparently randomly, in position or colour.

Is this a defect of this version of Google Earth, or a problem with the operation under Linux (I read somewhere GE does not operate well under Linux), or have I got something wrong? If it is a 'beta' problem, I can wait until it is a stable release. Incidentally, several answers in the forums refer to a Google Earth stable version, but I cannot find this. I used the version referred to in one of the answers in the forum (Question 143643 again), which gave me the version number above.

Best Regards
KeithW

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu googleearth-package Edit question
Assignee:
No assignee Edit question
Solved by:
kwardill
Solved:
2011-03-11
Last query:
2011-03-11
Last reply:
2011-03-09
Raymond Trim (raytrim83) said : #1

Download the full repository from MEDIBUNTU. This will contain Google Earth version 5.... and is stable. Once MEDIBUNTU is downloaded you will be able to access GE through the Software Centre but make sure you install GE and not Googleearth -package. I am running this OK on Ver 10.10.

kwardill (kwardill) said : #3

Thanks for the input Raymond,

I am no expert, so if I got this wrong, please forgive a beginner.
I pasted the commands from your link into a terminal, and it started to download the repository stuff as below

--2011-03-10 20:24:34-- http://www.medibuntu.org/sources.list.d/maverick.list
Resolving www.medibuntu.org... 88.191.127.22
Connecting to www.medibuntu.org|88.191.127.22|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 286 [text/plain]
Saving to: `/etc/apt/sources.list.d/medibuntu.list'

100%[======================================>] 286 --.-K/s in 0s

2011-03-10 20:24:44 (22.0 MB/s) - `/etc/apt/sources.list.d/medibuntu.list' saved [286/286]

Hit http://ftp.gts.lug.ro maverick Release.gpg
Ign http://ftp.gts.lug.ro/ubuntu/ maverick/main Translation-en
Ign http://ftp.gts.lug.ro/ubuntu/ maverick/main Translation-en_US
 ...............................etc, etc
then I got the following......
Hit http://packages.medibuntu.org maverick/non-free i386 Packages
E: Could not get lock /var/lib/dpkg/lock - open (11: Resource temporarily unavailable)
E: Unable to lock the administration directory (/var/lib/dpkg/), is another process using it?

I don't know of anything using the administration directory, so I switched off, rebooted, and started again, but got the same result.

Any help will be gratefully received.
Keith.

Raymond Trim (raytrim83) said : #4

The problem you have is nothing to do with the installation from Medibuntu. It is connected with a previous failed software download/installation - quite possibly when you were installing GE from Googleearth-package - something has not finished off properly and you need to find out what. I had this very problem once when using Googleearth-package and got in such a mess I had to do a clean install of Ubuntu OS which is why I never touch Googleearth -package now. I suspect you will get the same error if you try and install anything through either the Software Centre or the package manager. In fact only this last weekend I had the very same errors related to something entirely different and could not sort it out, so I invested in a 16GB memory stick to save everything and did a clean install as being the quickest and most efficient way of resolving the matter. You could try submitting another question about just the error messages when someone more able than myself may well be able to solve the problem without resorting to a clean install.

kwardill (kwardill) said : #5

Hi, Raymond,
OK, I have become thoroughly fed up with this GE - I left Windoze because of the problems, and now it seems Google is as bad. When I have time, I will do a new install of Ubuntu, and forget trying to install Google Earth at all.

For information (if it helps) - as far as I am aware, I have had no failures when installing something. The last thing I tried to install was Google Earth from their site - which incidentally it calls a 'Stable Release' - and that resulted in this cry for help. It did apparently install but wouldn't start up, then I came across Eliah Kagans suggestion to install lsb-core. At that point, GE started up, but had the radial map distortions I described earlier.

 I removed it completely, and all references to Google Earth, GE Package, etc using the Synaptic Manager, and went through the process you suggested above, at which point I got the error messages. I have just once again tried to install GE from the Google download, and it has installed and will run (presumably lsb-core is still on my machine), but it still shows the distortions, so I removed it again.

It would seem to me that not only is there a problem with Google Earth, but also within Ubuntu, if you re suggesting there is no way to clear this locked directory without a fresh install - or is it still locked now, because I could install Google Earth OK, as I have described.

Anyway, life is too short for this hassle - I'm much happier with Ubuntu than WIndoze, so I'll manage without Google Earth

Thanks for trying to help
Regards
Keith

Raymond Trim (raytrim83) said : #6

Hello Keith Glad you have got more or less sorted. To get the locked directory you do not need a total installation failure, just a minor problem can cause it and I still reckon the Googleearth-package is the prime candidate. I have never got GE to work properly when downloaded from the Google website which is why now I only use the version which comes from the MEDIBUNTU full repository (which I always download anyway) and accessed through the Software Centre/Synaptic Package Manager. I am running GE quite OK having got it through this route. I have been using Ubuntu for several years now and GE has always been a pain in the bum until quite recently. To tell if your directory is still locked just run the Update Manager - if that will not work you really will need a fresh install. Take a look at question 148666 and in particular take the actions suggested by Marcobra in the first bit of his answer - it will not do any harm and may just solve the problem. Finally do you know you can buy (£3.99) Ubuntu discs from www.thelinuxshop.co.uk if you need a disc for a fresh install ( version 11.04 is out in April ).

Regards, Ray

kwardill (kwardill) said : #7

Hi Ray,

Thanks for the info - I'll try the update manager tomorrow, see what happens. Unubtu is no problem, I have the downloaded ISOs. Its all a bit frustrating though - I have a reasonably good background with Windows - been forced to use it for years in business, so my opinion of it is really low. I tried various Linux variants over the years, but was never happy until I came across Ubuntu. THe machine I have now was bought only for Ubuntu, with the intention that if all worked well, I would reconfigure my original machine and my laptop with Ubuntu. I have to say up to messing about with Google Earth, all has gone very well, with only a couple of minor self-induced cockups, solved by the guys here. What is really annoying me is not Ubuntu, but the fact that Google is touting the latest Linux version of GE as 'stable' - what the hell are they doing? Clearly there is a problem - you only have to browse through the problems people have raised on this forum - maybe some-one in Ubuntu support should flag up a warning on the site that Google Earth is unreliable, and draw Googles attention to it - especially with increasing use of Linux.

Thnaks for the suggestion of looking at Marcobras answer, but I can't really be bothered with that - I view OSs and applications in the same way I view a screwdriver - it is a tool, and I have no intention of spending my time tinkering with getting the tool to work rather than using it - if its broke, chuck it away - lifes too short.

Thanks for the help - do doubt I'll back here with another problem sometime - at least someone is trying to help, unlike WIndoze.

Regards, Keith