Google Earth on Ubuntu 10.10?

Asked by ChristianM on 2011-02-01

Hi there
Just downloaded the Google Earth app for Linux as a bin-file.
When I double-click the file it asks which program to open it with.
Being new to Ubuntu/Linux, I do not know how to do this installation.

How do you install?
Can Google Earth at all run on Ubuntu 10.10?

Any advise is acknowledged, thank you.

Best,
ChristianM

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu googleearth-package Edit question
Assignee:
No assignee Edit question
Solved by:
ChristianM
Solved:
2011-02-01
Last query:
2011-02-01
Last reply:
2011-02-01
ChristianM (stokkemarken) said : #1

I tried the following that was recommended to another user

cd ~; wget https://dl-ssl.google.com/linux/direct/google-earth-stable_current_i386.deb; sudo dpkg -i ./google-earth-stable_current_i386.deb; rm ./google-earth-stable_current_i386.deb

it worked fine, Google Earth is apparently installed and listed under Programs->Internet but it does not start when I click on it.

ahambidge (ahambidge) said : #2

Hello,

You can install it from the Synaptic Package Manager. Search for Google and install.

Regards,

Allan :)

ChristianM (stokkemarken) said : #3

Allan,
thanks for your reply.
In the Synaptic PM I found google-earth-stable and googleearth-package and installed these, restarted the computer and still google earth is not starting ,,, please advise :-)

Regards,
Christian

ChristianM (stokkemarken) said : #4

Do I need to install all Google related files?

If you mean, do you need to install all packages that have "google" in their name or that are developed by Google, then no, you do not. For example, you do not need chromium-browser or google-chrome installed to run Google Earth. If you mean something else, please explain.

First, try installing the package lsb-core, and see if that makes Google Earth work.

If not, then in Synaptic, completely remove ("Mark for Complete Removal") the google-earth-stable and googleearth-package packages. Apply that operation. Search for google-earth-stable. At this point, it should *not* even be listed as a package that can be installed. Assuming that is the case, now install the package googleearth-package. (If google-earth-stable is still listed, please post again.)

Then quit the Synaptic Package Manager and open a Terminal window (Applications > Accessories > Terminal). Run these two commands, by pasting them in (or typing them in exactly), and pressing enter after each one. Please note that the first command deletes the Google Earth .bin file in your home directory, and any versioned Google Earth package files. (The second command will create its own versions of these files; we want to make sure they're the ones that get used in subsequent steps.) So if those files don't exist in your home directory, then the first command will spit out error messages, but that's OK, you can continue on with the the second command even if the first one produces errors.

rm GoogleEarthLinux.bin googleearth_*.deb
make-googleearth-package

The second command may take a while--that's OK. If the last line of output from the second command is "Unrecognized Google Earth version (use --force to build anyway)" then run this command, which may take a while:

make-googleearth-package --force

Do *not* run that command if the first make-googleearth-package command didn't print the message about "--force".

The make-googleearth-package command (whichever one took a long time) may produce a lot of warning messages. That's probably OK, and you can continue on with the next step, which is to run the command:

sudo dpkg -i googleearth_*.deb

That command might prompt you for your password. While entering it, you will not see any placeholder characters (like *). That's OK. Just type in your password and press enter.

Finally, run the command:

googleearth

If that successfully starts up Google Earth, then you might also be able to run it from the menu. If it doesn't successfully run it, or it does but you still cannot run it from the menu, then copy all the text in the Terminal (Edit > Select All; Edit > Copy) and paste it here. It should provide useful diagnostic information for solving your problem.

marcus aurelius (adbiz) said : #6

easiest and surefire way to install google earth is

1) go into software sources and check the canonical partners selection
2) go into terminal and type "sudo apt-get install update"
3) in terminal, type "sudo apt-get install upgrade"
4) in terminal, type "sudo apt-get install google-earth"

the program will be downloaded and installed automatically for you. no need to dkpg and chmod and all the unnecessary stuff.

@marcus

ChristianM already has Google Earth installed. It fails to run. On Maverick, this is almost always because of the undeclared dependency on lsb-core. That is why, at the beginning of my long post, I said:

"First, try installing the package lsb-core, and see if that makes Google Earth work."

If that works, then neither your method of reinstalling Google Earth, nor mine, should be used.

However, if that does not work, then reinstalling Google Earth makes sense. But your method does not work! I am not sure how you ever managed to get the command "sudo apt-get install google-earth" to work on any Ubuntu system *ever*, since the package google-earth is not provided by any of the official repositories (including the Canonical Partners repository), nor by medibuntu. The package googleearth (without the dash) is provided by the unofficial medibuntu repository, but only in Ubuntu versions up to Lucid. It is NOT available in Maverick. See http://packages.medibuntu.org/lucid/index.html and http://packages.medibuntu.org/maverick/index.html.

ChristianM,

If you want the latest-n-greatest GoogleEarth direct from google to work on 10.10 follow these steps:

 sudo apt-get install lsb-core

 chmod +x GoogleEarthLinux.bin
 ./GoogleEarthLinux.bin --target /tmp/ge

  [RESULTS IN AN ERROR!!!]

 cd /tmp/ge/setup.data/bin/Linux/x86/
 mv setup.gtk setup.gtk2
 cd /tmp/ge
 sudo ./setup.sh

Good luck,
George

ChristianM (stokkemarken) said : #9

Dear all - this is absolutely fantastic! My first support request reg. Ubuntu, and what a response rate.

Actually, I did the "First, try installing the package lsb-core, and see if that makes Google Earth work."

And it works! - Thanks to all of you, however.

Cheers,
Christian