dowloaded google earth but it will not open, lucid lynx

Asked by xzimppledink on 2010-12-26

Lucid lynx, I downloaded Google earth but it will not open. Icon appears but clicking it does nothing. Beginner in Linux.

Question information

English Edit question
Ubuntu googleearth-package Edit question
No assignee Edit question
Last query:
Last reply:
mycae (mycae) said : #1

I assume you downloaded the ./

Try using their ".deb" installers.

Alternatively, another globe viewer is "Marble", which is in the software repository, so is easy to install.

How did you install it?
Do you have the ability to enable 3D effects?

xzimppledink (xzimppledink) said : #3

When I click on the icon absolutely nothing happens. I went to Google Earth, clicked on Ubuntu 32 bit installation and was presented with a window "how to install", it has preselected the method with a Debian installation program. I clicked to proceed and waited until it was finished. I opened up "INTERNET" under applications menu and selected Google Earth icon, placed it on the desktop. I then tried to activate by clicking on the icon . Nothing at all.

If you uninstall the app then enable the partner ppa you can use software centre to install that way

xzimppledink (xzimppledink) said : #5

Ok I went to software center and deleted Google earth.I then searched for partner PPA but found nothing.perhaps I need more information on partner PPA, what and where is it?

mycae (mycae) said : #6

Can you open a terminal (Ctrl+Alt+T), then provide the output from these commands




mycae (mycae) said : #7

Of course, installing google-earth from the software centre first.

marcus aurelius (adbiz) said : #8

foolproof way of installing google earth

sudo apt-get install google-earth

xzimppledink (xzimppledink) said : #9

Thanks all you helpers but I've spent way too much time on this. don't need it that bad, thanks just the same but i'm back to windows, it works without all the hassle.

Can you help with this problem?

Provide an answer of your own, or ask xzimppledink for more information if necessary.

To post a message you must log in.