Google Earth 10.10 installation

Asked by Greg on 2010-11-30

I am still trying to get Google Earth to run on 10.10. I have used the sudo suggestions that have been e-mailed to me with no success. I have used sh till I am blue in the face. Somebody who has done this please tell me how you do it.
greg

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu googleearth-package Edit question
Assignee:
No assignee Edit question
Last query:
2010-12-02
Last reply:
2010-12-02
marcus aurelius (adbiz) said : #1

sudo apt-get update
sudo apt-get upgrade
sudo apt-get install google-earth

should do the trick.

Marcus' directions above are not quite complete.

 $ sudo apt-get install googleearth-package
 $ make-googleearth-package [actual used was: $ make-googleearth-package --force ]
 $ sudo dpkg -i googleearth_5.2.1.1588+0.5.7-1_i386.deb

Hope that helps,
George

williamts99 (williamts99) said : #3

Open up a terminal(ctrl+alt+t or Applications>Accessories>Terminal) and issue the following commands. Note: Everything in Linux is case sensitive, please use copy and paste, it is all one line. :)

wget http://dl.google.com/earth/client/current/GoogleEarthLinux.bin && chmod u+x GoogleEarthLinux.bin && ./GoogleEarthLinux.bin

Then follow the on screen instructions.
If this has helped you solve your issue, please mark this as best answer.

Best Regards,
Will

Greg (gsmorgansen) said : #4

Hi William.

I ran your script with the following result...

Verifying archive integrity... All good.
Uncompressing Google Earth for GNU/Linux 6.0.0.1735..............................................................
setup.data/setup.xml:1: parser error : Document is empty

^
setup.data/setup.xml:1: parser error : Start tag expected, '<' not found

^
Couldn't load 'setup.data/setup.xml'

What do you suggest?

Greg

----- Original Message -----
From: "williamts99" <email address hidden>
To: <email address hidden>
Sent: Tuesday, November 30, 2010 11:42:11 PM
Subject: Re: [Question #136104]: Google Earth 10.10 installation

Your question #136104 on googleearth-package in ubuntu changed:
https://answers.launchpad.net/ubuntu/+source/googleearth-package/+question/136104

williamts99 proposed the following answer:
Open up a terminal(ctrl+alt+t or Applications>Accessories>Terminal) and
issue the following commands. Note: Everything in Linux is case
sensitive, please use copy and paste, it is all one line. :)

wget http://dl.google.com/earth/client/current/GoogleEarthLinux.bin &&
chmod u+x GoogleEarthLinux.bin && ./GoogleEarthLinux.bin

Then follow the on screen instructions.
If this has helped you solve your issue, please mark this as best answer.

Best Regards,
Will

--
If this answers your question, please go to the following page to let us
know that it is solved:
https://answers.launchpad.net/ubuntu/+source/googleearth-package/+question/136104/+confirm?answer_id=2

If you still need help, you can reply to this email or go to the
following page to enter your feedback:
https://answers.launchpad.net/ubuntu/+source/googleearth-package/+question/136104

You received this question notification because you are a direct
subscriber of the question.

williamts99 (williamts99) said : #5

Sounds like there is a problem with the installer, I would message Google about fixing it.
https://help.ubuntu.com/community/GoogleEarth

You can install from the Medibuntu repositories, enter the following in the terminal:
sudo wget --output-document=/etc/apt/sources.list.d/medibuntu.list http://www.medibuntu.org/sources.list.d/$(lsb_release -cs).list && sudo apt-get --quiet update && sudo apt-get --yes --quiet --allow-unauthenticated install medibuntu-keyring && sudo apt-get --quiet update && sudo apt-get install googleearth

While you are at it, you might also want to install the ubuntu-restricted-extras package afterwards.
sudo apt-get install ubuntu-restricted-extras

Best Regards,
Will

williamts99 (williamts99) said : #6

Sounds like there is a problem with the installer, I would message Google about fixing it.
https://help.ubuntu.com/community/GoogleEarth

You can install from the Medibuntu repositories, enter the following in the terminal:
sudo wget --output-document=/etc/apt/sources.list.d/medibuntu.list http://www.medibuntu.org/sources.list.d/$(lsb_release -cs).list && sudo apt-get --quiet update && sudo apt-get --yes --quiet --allow-unauthenticated install medibuntu-keyring && sudo apt-get --quiet update && sudo apt-get install googleearth

While you are at it, you might also want to install the ubuntu-restricted-extras package afterwards.
sudo apt-get install ubuntu-restricted-extras

Best Regards,
Will

Greg (gsmorgansen) said : #7

Hi William.

The result of running the Medibuntu Googleearth script is as follows:

Package googleearth is not available, but is referred to by another
package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

Suggestions?

Greg

On Wed, 2010-12-01 at 17:52 +0000, williamts99 wrote:
> Your question #136104 on googleearth-package in ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/googleearth-package/+question/136104
>
> williamts99 proposed the following answer:
> Sounds like there is a problem with the installer, I would message Google about fixing it.
> https://help.ubuntu.com/community/GoogleEarth
>
> You can install from the Medibuntu repositories, enter the following in the terminal:
> sudo wget --output-document=/etc/apt/sources.list.d/medibuntu.list http://www.medibuntu.org/sources.list.d/$(lsb_release -cs).list && sudo apt-get --quiet update && sudo apt-get --yes --quiet --allow-unauthenticated install medibuntu-keyring && sudo apt-get --quiet update && sudo apt-get install googleearth
>
> While you are at it, you might also want to install the ubuntu-restricted-extras package afterwards.
> sudo apt-get install ubuntu-restricted-extras
>
>
> Best Regards,
> Will
>

williamts99 (williamts99) said : #8

One last try, hopefully google will fix this sooner rather than later, but such is life with proprietary software :)

Create a .deb to install, and then installing it(note: this will take a while to complete):

sudo apt-get install googleearth-package && make-googleearth-package --force && sudo dpkg -i googleearth_6.0.0.1735+0.5.7-1_i386.deb

After that is finished, you will have Google Earth in the menu Applications > Internet > Google Earth
If Google Earth crashes, run as root and uncheck the 'show tips at the beginning' box.

sudo googleearth

Best Regards,
Will

Greg (gsmorgansen) said : #9

Hi Will.

How do I run it as root?

Greg

On Wed, 2010-12-01 at 18:47 +0000, williamts99 wrote:
> Your question #136104 on googleearth-package in ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/googleearth-package/+question/136104
>
> Status: Open => Answered
>
> williamts99 proposed the following answer:
> One last try, hopefully google will fix this sooner rather than later,
> but such is life with proprietary software :)
>
> Create a .deb to install, and then installing it(note: this will take a
> while to complete):
>
> sudo apt-get install googleearth-package && make-googleearth-package
> --force && sudo dpkg -i googleearth_6.0.0.1735+0.5.7-1_i386.deb
>
> After that is finished, you will have Google Earth in the menu Applications > Internet > Google Earth
> If Google Earth crashes, run as root and uncheck the 'show tips at the beginning' box.
>
> sudo googleearth
>
> Best Regards,
> Will
>

williamts99 (williamts99) said : #10

https://help.ubuntu.com/community/RootSudo

sudo googleearth

Best Regards,
Will

Can you help with this problem?

Provide an answer of your own, or ask Greg for more information if necessary.

To post a message you must log in.