Installing Google Earth in Ubuntu 10.04

Asked by Guy Andrew on 2010-05-22

New to Linux. Have installed Ubuntu 10.04. Now trying to install GoogleEarthLinux.bin in Terminal. I can get into the directory OK but cannot open/run the file. What should I type?

Have tried, to no avail:

guy@ubuntu:~$ cd ~ home/guy/downloads
guy@ubuntu:~$ sudo sh Google_Earth_bin_file
[sudo] password for guy:
sh: Can't open Google_Earth_bin_file
guy@ubuntu:~$ sudo sh GoogleEarthLinux.bin
sh: Can't open GoogleEarthLinux.bin
guy@ubuntu:~$ sudo sh Google_Earth_Linux_bin_file
sh: Can't open Google_Earth_Linux_bin_file
guy@ubuntu:~$ sudo sh Google Earth Linux bin file
sh: Can't open Google
guy@ubuntu:~$ sudo chmod +x GoogleEarthLinux.bin
chmod: cannot access `GoogleEarthLinux.bin': No such file or directory
guy@ubuntu:~$ sudo chmod +x GoogleEarthLinux.bin-file
chmod: cannot access `GoogleEarthLinux.bin-file': No such file or directory
guy@ubuntu:~$

What now?

Thanks

Guy

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu googleearth-package Edit question
Assignee:
No assignee Edit question
Solved by:
Erik Meitner
Solved:
2010-05-22
Last query:
2010-05-22
Last reply:
2010-05-22
Best Erik Meitner (e.meitner) said : #1

I think you are having a difficult time using the command line. Did you know Google Earth is available already packaged for installation in Ubuntu 10.04?:
https://help.ubuntu.com/community/GoogleEarth

But to continue...

"cd ~ home/guy/downloads" does not make sense(lets ignore the reasons why for now). Try just : cd /home/guy/downloads

If "sudo sh GoogleEarthLinux.bin" fails with "sh: Can't open GoogleEarthLinux.bin" then the file is not there. Did you run the command to list files in that folder?: ls
This should list all the files in the directory. Is the file there? If not, then find it. This may help find it:
find ~ -name GoogleEarthLinux.bin
(GoogleEarthLinux.bin is the name of the file you are looking for)

Found it? If so, continue reading.

Run:
sudo sh /path/to/GoogleEarthLinux.bin (where "/path/to" is the same as what the "find" command printed)

So the short version would have been:
cd /path/to/where/you/saved/GoogleEarthLinux.bin
sudo sh GoogleEarthLinux.bin

Marc Stewart (marc.stewart) said : #2

A small addition to Erik Meitner's answer:
the command line is also case sensitive, so you should probably use:
cd ~/Downloads
with a capital D, assuming you haven't renamed the default Downloads folder in Ubuntu.

You know when you've changed directory correctly because the prompt will change from:
guy@ubuntu:~$
to:
guy@ubuntu:~/Downloads$

Guy Andrew (guy-andrew) said : #3

Many thanks to you both, Erik and Marc. Google Earth now up and running! Regards, Guy

Guy Andrew (guy-andrew) said : #4

Thanks Erik Meitner, that solved my question.

Sipho Mkhwanazi (sipho411) said : #5

Hi l am also new to Linux and l have the same problem as Guy Andrew.

I downloaded GoogleEarthLinux.bin and have tried different approaches to install it with no success.
I have tried to (right click>OpenWith sh), (rightclick>Properties>Permissions>tick allow executing file as program) and recently verifying directory using (find ~ -name GoogleEarthLinux.bin) then the (sudo sh /path/to/GoogleEarthLinux.bin). Here is what l got?

siptech@ubuntu:~$ find ~ -name GoogleEarthLinux.bin
/home/siptech/Downloads/GoogleEarthLinux.bin
siptech@ubuntu:~$ sudo sh/home/siptech/Downloads/GoogleEarthLinux.bin
sudo: sh/home/siptech/Downloads/GoogleEarthLinux.bin: command not found
siptech@ubuntu:~$ sudo sh /home/siptech/Downloads/GoogleEarthLinux.bin
Verifying archive integrity... All good.
Uncompressing Google Earth for GNU/Linux 6.0.0.1735..............................................................
setup.data/setup.xml:1: parser error : Document is empty

^
setup.data/setup.xml:1: parser error : Start tag expected, '<' not found

^
Couldn't load 'setup.data/setup.xml'
siptech@ubuntu:~$

@Sipho Mkhwanazi

Please made your own question from here:

https://answers.launchpad.net/ubuntu/+source/googleearth-package/+addquestion

@Sipho Mkhwanazi

Please made your own question from here:

https://answers.launchpad.net/ubuntu/+source/googleearth-package/+addquestion