Can't Sign Code of Conduct

Asked by james.brantley on 2009-06-24

I have been trying to sign the Coc for about 2 hours no. My machine does not generate a new file when I run "gpg --clearsign UbuntuCodeofConduct-1.0.1.txt" I have searched the forum and have been unable to find an exact match to my error. Someone had the same error message but their solution did not work for me. Following is my error message-

gpg: can't open `UbuntuCodeofConduct-1.0.1.txt': No such file or directory
gpg: UbuntuCodeofConduct-1.0.1.txt: clearsign failed: file open error

The .txt file of the CoC is saved in my documents.

Sorry if I have overlooked a resolution for my problem, but like I say I have searched.

Thank, james.brantley

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gnupg Edit question
Assignee:
No assignee Edit question
Solved by:
Sam_
Solved:
2009-06-24
Last query:
2009-06-24
Last reply:
2009-06-24
Steven Danna (ssd7) said : #1

Just to be sure, are you certain that the CoC document is in the same directory as the one you are running the command in. Try the following:

1) Open a terminal (Applications->Accessories->Terminal).
2) Type: ls
3) Press <Enter>
4) This will output a a list of files in the current directory. If you do not see the file, use the "cd" command to move to the right directory. For instance you may have to type:

cd Documents

5) If you aren't certain where the file is try the following command:

find . -name UbuntuCodeofConduct-1.0.1.txt

That will output a the path of the file. You can copy and paste that path into the gpg command you were trying to run.

If none of this works, copy and past the all the output to the terminal that happened here and we can try to troubleshoot further.

Now I have created the .txt.asc file (thanks to going the pathway route) but now when I try to open it so I can paste it to sign the CoC I am told "Couldn't verify file: UbuntuCodeofConduct-1.0.1.txt.asc No valid signatures found. What did or didn't I do?

Steven Danna (ssd7) said : #3

That sounds like you haven't uploaded your key the the ubuntu keyserver yet. Did you already do that part of the directions? If so, on your launchpad page does it show you as having an OpenPGP key uploaded?

Yes I received a confirmation email that I had to respond to. How do I access my launchpad page?

Best Sam_ (and-sam) said : #5

That would be the one and yes it does shoe me as having an OpenPGP key.

Thanks Sam, that solved my question.