Can't importing an OpenPGP key to

Asked by Johan Ryberg

I'm trying to import my OpenPGP key to but either the instructions are wrong or there is something with the standard pgp package shipped with Ubuntu 8.10 beta fully updated.

The instructions says:
Change your OpenPGP keys

You can register your OpenPGP keys, which are created by software such as GnuPG. These are used to sign codes of conduct, modify bugs through the email interface, and to build and upload packages using Soyuz.
Importing an OpenPGP key

   1. Ensure you already have a key. In a terminal window, enter:

      gpg --list-keys <email address hidden>

      If you have no key, create one:

      gpg --gen-key

   2. Ensure the key has been uploaded to a keyserver. To do this:

      gpg --send-key key-id

   3. Enter your key fingerprint. Use:

      gpg --fingerprint key-id
Number 2, gpg --send-key XXXXXXX gives me this message in the terminal:
gpg: no keyserver known (use option --keyserver)
gpg: keyserver send failed: bad URI

Need advice

// rancor

Question information

English Edit question
Ubuntu gnupg Edit question
No assignee Edit question
Solved by:
Johan Ryberg
Last query:
Last reply:
Revision history for this message
Dan Trevino (dantrevino) said :

Question about how to use gpg.
the --send-keys option requires --keyserver

     --send-keys key IDs
              Similar to --export but sends the keys to a keyserver. Finger‐
              prints may be used instead of key IDs. Option --keyserver must
              be used to give the name of this keyserver. Don’t send your com‐
              plete keyring to a keyserver --- select only those keys which
              are new or changed by you.

You can find this help by typing "man gpg" at the command line. There is also a wiki page for gpg:

I think we need to have instructions updated. For step 2 you should use:

gpg --send-keys --keyserver <key-id>


Revision history for this message
Johan Ryberg (jryberg) said :

Yes! It must be up to date because it's on the official home page and as a help for new users it must always be updated. I did never think about that the syntax has changed and I thought this kind of information was updated by some kind of "staff".


// rancor