which is the private gpg key?

Asked by sun_tzu on 2008-01-21

Hi I'm still trying to sign up the code of conduct. I know I am boring and you might think that if I am so ignorant I should consider resigning instead of signing. But still I am in love with this project, and am not a person who gives up easily. I gave my fingerprint to ubuntu server and received to my gmail account the encrypted e-mail to answer. I followed all the instructions and downloaded the firefox modification that allow to decrypt the contents of the e-mails. Anyway when i ask to decrypt the conten of the e-mail the program asks me my private key. I tried many, but none seem to work. To generate my keys I used seahorse. Can anybody tell me which one is the private key i have to insert in that blody dialog box?
Thanks from despair.
Sun_tzu

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gnupg Edit question
Assignee:
No assignee Edit question
Solved by:
Omegamormegil
Solved:
2008-01-25
Last query:
2008-01-25
Last reply:
2008-01-24

You need to type in the password you set when making the key, not the actual key itself.

sun_tzu (marcoapuleiomiglia) said : #2

I did not type any password. The system only asked me to type a passphrase.

Best Omegamormegil (omegamormegil) said : #3

Did you try typing in the passphrase? I don't believe you ever have to give out the Private key. Check out this link for the instructions on validating the Key on Launchpad: https://help.ubuntu.com/community/GnuPrivacyGuardHowto#head-a6c9b1c3125d9af57c4a7e0f245225df74c2ead8

Perhaps it will clarify where you are getting tripped up.

I did this recently, and boy, was it complicated. The instructions in the link above really helped me.

sun_tzu (marcoapuleiomiglia) said : #4

Thanks Omegamormegil
Actually it ws the passphrase that worked.
Anothr thing I went through all the download of the code of conduct, but I can't open the file 'UbuntuCodeofConduct-1.0.1.txt.asc'. I tried with 'Open with "Decrypt File"' but it says "couldn't decrypt file .........";"no data". How does it work?
Thaks for any help
Marco

Try highlighting the PHP MESSAGE part of the email, then right-click and choose FireGPG>Decrypt

That's what worked for me if I remember correctly..

sun_tzu (marcoapuleiomiglia) said : #6

Yes this has worked for me as well. Thanks David.

sun_tzu (marcoapuleiomiglia) said : #7

Thanks Omegamormegil, that solved my question.