can't sign ubuntu code of conduct

Asked by Thomas

tom@tom-laptop:~$ gpg --clearsign UbuntuCodeofConduct-1.1.txt

You need a passphrase to unlock the secret key for
user: "*****************************************>"
2048-bit RSA key, ID BC908922, created 2011-08-03

gpg: gpg-agent is not available in this session
gpg: can't open `UbuntuCodeofConduct-1.1.txt': No such file or directory
gpg: UbuntuCodeofConduct-1.1.txt: clearsign failed: file open error

tried loads of times. can't find an answer in any other questions, sure its there ^.^

i am in the right dir and the file is in the dir.

can anyone enlighten me? xD

bit of a noob, so try to dumb down instructions please.



Question information

English Edit question
Ubuntu gnupg Edit question
No assignee Edit question
Last query:
Last reply:
Revision history for this message
Eliah Kagan (degeneracypressure) said :

gpg says that the file is not where you are, so let's investigate this. Please paste this command into the Terminal and press enter to run it:

ls -l UbuntuCode*; echo; find ~ -name UbuntuCodeofConduct-1.1.txt

Wait for that to complete (you'll see a $ _ prompt like before), then select all the new text in the Terminal (starting with the beginning of the line on which you entered the above command), copy it to the clipboard, and paste it here.

(If the output simply enables you to solve the problem--for example, if it turns out that you were in the wrong directory after all--then you can mark this question as Solved.)

Can you help with this problem?

Provide an answer of your own, or ask Thomas for more information if necessary.

To post a message you must log in.