GnuCash crashes when opening file in Ubuntu 16.04

Asked by bsa

After upgrading to Ubuntu 16.04, GnuCash starts crashing when opening my data file with the error provided below.

Please note that after the crash, restarting GnuCash gives me the option to open the same file in Read-Only mode. If I choose this option, I'm then able to open the file successfully for Read-Only.

GnuCash installed version is : 1:2.6.12-1

The error is :

*** Error in `gnucash': free(): invalid pointer: 0x00007f934c001500 ***

======= Backtrace: =========

Thanks for your support !

Question information

English Edit question
Ubuntu gnucash Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
actionparsnip (andrew-woodhead666) said :

I suggest you report a bug

Revision history for this message
OrelEagle (oreleagle) said :

I had the same problem. In my case I solved it by changing the locale for formats (dates, numbers, currency) to the one used when creating the scheduled transactions.
Another option is to open it read only, remove all scheduled transactions and save it to another location. Or you edit all scheduled transaction updating the number format. For example, if you use US formatting: 1,000,000.00, or for German: 1.000.000,00

Revision history for this message
bsa (bsa-tmp0) said :

You're right, the issue I had was also caused by an invalid format in some scheduled transaction.
Opening the file read-only and deleting these transactions solved the issue,

Thanks for your help !