GnuCash crashes when opening file in Ubuntu 16.04

Asked by bsa on 2016-05-01

After upgrading to Ubuntu 16.04, GnuCash starts crashing when opening my data file with the error provided below.

Please note that after the crash, restarting GnuCash gives me the option to open the same file in Read-Only mode. If I choose this option, I'm then able to open the file successfully for Read-Only.

GnuCash installed version is : 1:2.6.12-1

The error is :

*** Error in `gnucash': free(): invalid pointer: 0x00007f934c001500 ***

======= Backtrace: =========
/lib/x86_64-linux-gnu/libc.so.6(+0x77725)[0x7f93692ee725]
/lib/x86_64-linux-gnu/libc.so.6(+0x7ff4a)[0x7f93692f6f4a]
/lib/x86_64-linux-gnu/libc.so.6(cfree+0x4c)[0x7f93692faabc]
/usr/lib/x86_64-linux-gnu/gnucash/libgnc-gnome.so.0(+0x4cb17)[0x7f936b410b17]
/usr/lib/x86_64-linux-gnu/gnucash/libgnc-gnome.so.0(gnc_sx_sxsincelast_book_opened+0xef)[0x7f936b41241f]
/usr/lib/x86_64-linux-gnu/gnucash/gnucash/libgncmod-engine.so(+0x57c6e)[0x7f936abe9c6e]
/lib/x86_64-linux-gnu/libglib-2.0.so.0(g_hook_list_marshal+0x54)[0x7f9369897884]
/usr/lib/x86_64-linux-gnu/gnucash/gnucash/libgncmod-engine.so(gnc_hook_run+0x98)[0x7f936abeb208]
/usr/lib/x86_64-linux-gnu/gnucash/gnucash/libgncmod-gnome-utils.so(+0x62b87)[0x7f936b12ab87]
gnucash(+0x328e)[0x55969d75a28e]
/usr/lib/x86_64-linux-gnu/libguile-2.0.so.22(+0x79c5d)[0x7f936a232c5d]
/usr/lib/x86_64-linux-gnu/libguile-2.0.so.22(+0x5258a)[0x7f936a20b58a]
/usr/lib/x86_64-linux-gnu/libguile-2.0.so.22(+0xefd33)[0x7f936a2a8d33]
/usr/lib/x86_64-linux-gnu/libguile-2.0.so.22(scm_call_4+0x43)[0x7f936a215283]
/usr/lib/x86_64-linux-gnu/libguile-2.0.so.22(+0x52d21)[0x7f936a20bd21]
/usr/lib/x86_64-linux-gnu/libguile-2.0.so.22(scm_c_with_continuation_barrier+0x45)[0x7f936a20be05]
/usr/lib/x86_64-linux-gnu/libguile-2.0.so.22(+0xd2bbc)[0x7f936a28bbbc]
/usr/lib/x86_64-linux-gnu/libgc.so.1(GC_call_with_stack_base+0x22)[0x7f9365cba952]
/usr/lib/x86_64-linux-gnu/libguile-2.0.so.22(scm_with_guile+0x38)[0x7f936a28bfe8]
/usr/lib/x86_64-linux-gnu/libguile-2.0.so.22(scm_boot_guile+0x35)[0x7f936a232e35]
gnucash(main+0x495)[0x55969d759d35]
/lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xf0)[0x7f9369297830]
gnucash(_start+0x29)[0x55969d759de9]

Thanks for your support !

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gnucash Edit question
Assignee:
No assignee Edit question
Solved by:
bsa
Solved:
2016-05-12
Last query:
2016-05-12
Last reply:
2016-05-01

I suggest you report a bug

OrelEagle (oreleagle) said : #2

I had the same problem. In my case I solved it by changing the locale for formats (dates, numbers, currency) to the one used when creating the scheduled transactions.
Another option is to open it read only, remove all scheduled transactions and save it to another location. Or you edit all scheduled transaction updating the number format. For example, if you use US formatting: 1,000,000.00, or for German: 1.000.000,00

bsa (bsa-tmp0) said : #3

You're right, the issue I had was also caused by an invalid format in some scheduled transaction.
Opening the file read-only and deleting these transactions solved the issue,

Thanks for your help !