Put GnuCash 2.6.11 in Xenial LTS instead of buggy version

Asked by Tommy Trussell on 2016-02-27

According to the release schedule [1] Ubuntu Xenial's Debian Import Freeze occurred a few days ago. While the import picked up the 2.6.11 version of the documentation package, the software is still at version 2.6.9. I believe the mis-match should not be a problem for the documentation package.

HOWEVER I wish the repository did not contain GnuCash 2.6.9. That version has a major QIF import bug and a few other important things that were fixed in 2.6.11 (see the January 2016 announcement at gnucash.org for a list of fixes).

As we have seen, some fraction of Ubuntu users (including me) plus a number of other linux distros use the Ubuntu LTS (Long Term Support) repository. That's why for almost two years we on the support lists have had to talk many folks through updating from the unusually buggy version 2.6.1 of GnuCash in the Ubuntu 14.04 LTS "Trusty" repository.

Someone else already created Bug #1550144 to petition to get 2.6.11 into Ubuntu 16.04 LTS "Xenial," as described in [2], but it's not completely ready.

[1] https://wiki.ubuntu.com/XenialXerus/ReleaseSchedule
[2] https://wiki.ubuntu.com/FreezeExceptionProcess

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gnucash Edit question
Assignee:
No assignee Edit question
Solved by:
Tommy Trussell
Solved:
2016-04-18
Last query:
2016-04-18
Last reply:
2016-02-28

According to https://tracker.debian.org/pkg/gnucash 2.6.11 made it into Debian Testing on January 21 (2016) and into Jessie backports on February 2. So the tested Debian package for 2.6.11 is available.

The package also exists for Trusty and Wily at getdeb.net

I suggest you report a bug, just for visibility

@actionparsnip do you mean in addition to Bug #1550144 ?

A different bug got the attention needed and the package was sponsored late in the game, but we got the latest version into the LTS repository. Thank you to everyone who helped!