How to recover GnuCash menu access key that disappeared

Asked by John Marter on 2011-03-03

As I was entering receipts in GnuCash, somehow a keyboard shortcut (menu access key) that I was using disappeared. Specifically, when in the register "Alt-A p" opens the splits on the current transaction. This access key has disappeared as I worked during my session. The p in the word Split in the Actions menu is no longer underlined and although Alt-A still opens the Action menu "p" does not activate the "Split Transaction" item.

I looked through the other menus, and no other menu entry seems to be affected.

I did a diff of my home directory against a backup from a couple of days ago. Searching (case insensitive) on "split" did not find much. There was one file that seemed promising, ~/.gnucash/accelerator-map. It had the following line (along with others) added.

; (gtk_accel_path "<Actions>/GncPluginPageRegisterActions/ActionsStockSplitAction" "")

Unfortunately, any change I made to this file (even deleting it) seemed to have no effect. Upon exiting GnuCash it was restored to the same contents. Also, this seems to be related to Accelerator keys, not the menu access keys, but it's hard to be sure. I can post the entire diff of that file (63 lines) if that would be helpful.

This behavior remains even if I log out and log back in.

There is one promising note. I logged in as another user, and the menu accelerator still worked for that user. So it does suggest that there is a configuration file somewhere in my home directory that I can use to fix this. I am pretty sure that the configuration is not in the financial data file. I tried opening a file that was a couple of years old and that did not fix the problem.

One puzzling side alley in this adventure is section 2.3.7 in the gnucash-guide at the bottom of this page: http://www.gnucash.org/docs/v2.2/C/gnucash-guide/basics-interface1.html . It makes the distinction between menu access keys (which is my problem) and accelerator keys. It is puzzling for two reasons. First it says that the menu access keys cannot be changed (by users) but that is what happened to me. Second, it describes how to set the Accelerator keys (which I thought my be a decent work-around) but I cannot see how to put that into action. I cannot find the "Menu and Toolbar" preference panel that it refers to.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gnucash Edit question
Assignee:
No assignee Edit question
Solved by:
John Marter
Solved:
2011-03-05
Last query:
2011-03-05
Last reply:
John Marter (gjmarter) said : #1

50% of this problem is an unreproducible mystery and 50% is a font problem.

The font problem is that lower case p in the Ubuntu font does not show an underline. You can see this on the font tab of the Appearance preferences panel. The "subpixel smoothing" option has the "p" underlined. With the Ubuntu font you cannot tell, but with every other font I tried it was obvious.

When I said that other menu entries were not affected, I failed to notice that all of the others with a P used an uppercase P.

As to why the keyboard shortcut did not work, I do not know, but it is working again now. Maybe I was just hitting the "p" at an awkward angle or something.

Robert L Brush III (shade304) said : #2

To clarify on exit GnuCash overwrites the accelerator file, so to successfully edit requires to close the program down, then make the changes, then reopen. This is to catch any changes made when using the program, although for almost all users the ability to change the shortcuts is not enabled by default. A google search returns this page on searching for GnuCash accelerator, so this info my be useful for the rest, I know it is late..