GNS3 0.6 not saving configurations on Jaunty

Asked by Eduardo Collado on 2009-04-19

I'm trying to use GNS3 over Jaunty for testing purposes and I've seen, it is not working propertly (I installed the version from apt).
The program it is running with no problem except the moment you try to save the configuration, GNS3 it is not saving any data in the hard disk.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gns3 Edit question
Assignee:
No assignee Edit question
Solved by:
Eduardo Collado
Solved:
2009-04-21
Last query:
2009-04-21
Last reply:
2009-04-19
Chaker ZAAFOURI (zaafouri) said : #1

Do you have permission to write on the GNS archives directory ?
Do you have some Errors ? Can you paste it here plz, it will be helpful =)

Eduardo Collado (edu) said : #2

I've checked permissions all it is ok.
First time I create a project I can save it, but, next times I've tried to save or save .net file with another name it is impossible.
Sorry, but I cannot see any error or log in the system neither the application.
The problem it is easy to reproduce.
1.- Open GNS and create a new project
2.- Try to save with another name or after modify the project, ie putting a new router (no config in the router or anything more necessary to reproduce, at least for me)

Eduardo Collado (edu) said : #3

I have tried to download GNS3 from Debian package repository (http://packages.debian.org/sid/gns3), I have exactly the same problem, it seems a problem in another place, not it the package. Maybe Python????

Eduardo Collado (edu) said : #4

Solved !!!

I've found a way to make work GNS3. For any reason I need to open GNS3 indicating the file .net doing something like this:

gns3 /path .../file.net

If I open gns3 and next try to open my .net file using File -> Open it doesn't work.

Hi,

In the openFile method in Workspace class (/var/lib/python-support/python2.x/GNS3/Workspace.py/Workspace.py module), you'll find the following code:
================
        if path != None:
            try:
---> if str(selected) == 'NET file (*.net)':
                    # here the loading
                    self.projectWorkdir = None
                    self.projectConfigs = None
                    self.projectFile = None
                    self.load_netfile(path)
                    globals.GApp.topology.changed = False
            except IOError, (errno, strerror):
                QtGui.QMessageBox.critical(self, 'Open', u'Open: ' + strerror)
================

The condition in the if statement seems that isn't true in any case so the "load_netfile" method never gets called and the file isn't loaded. A workaround for this problem is just to comment out the if statement line and the file opening won't fail.

I guess that the condition was written to prevent opening a file that hasn't a '.net' extension. However maybe that part of the code isn't currently working because of a change in the file selection dialog in the QT library.

Best regards,
    Javier

arielcosta (arielcosta) said : #6

Hi,

if you run GNS3 in root mode, with sudo, it's work correctly. Maybe is permissions problem in the module.

gBug (gigalimit20) said : #7

I can confirm what ArielCosta said!

Running the GNS3 as a root solved the problem [which I consider a temp solution]. I guess the problem has to do with permissions like he rightly high-lighted