synaptic cache error - can't find archive to reinstall

Asked by Domenico on 2007-05-28

Hello, I try to write in English but I'm Italian, then I apologize from now for my "terrible" English.
So, I've tried to install driver for my printer (Brother DCP-750CW, look to http://solutions.brother.com/linux/en_us/index.html ) , but, unfortunatly, something wrong happened and the installation has failed. But the problem is that now also Synaptic shows an error like (I translate the message from Italian:-))..) "the package <xxxx > have to be reinstalled but it's impossible to find an archive for it. Internal error opening cache". May help me? I'm using Ubuntu 6.06 LTS Dapper Drake, I'm using kernel: [17179569.184000] Linux version 2.6.15-28-386 (buildd@terranova) (gcc version 4.0.3 (Ubuntu 4.0.3-1ubuntu5)), my hardware database id is 0620f0ba9a686b6fe2976977de393439.

Thank you very much for your attention.

Domenico

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gnome-utils Edit question
Assignee:
No assignee Edit question
Solved by:
Domenico
Solved:
2007-06-06
Last query:
2007-06-06
Last reply:
2007-06-04
Markus Thielmann (thielmann) said : #1

Thanks for your question.

1) Open a Terminal window (Applications->Accessories)
2) Copy the following command to this window and execute it by pressing <Enter>: sudo dpkg --force-remove-reinstreq --remove <xxx>

Please replace <xxx> with the name of the package. After that, Synaptic should continue to work again.

Domenico (waldo111) said : #2

Thank you for you attention, but also "sudo dpkg --force-remove-reinstreq --remove...." return error 127, internal cache error. Moreover I can't use Synaptic at all: it starts and after a while goes down alone.

The .deb file you tried to install failed, can you try to re-install it?

You may have to redownload it, and save it on your desktop (or somewhere else you can easily find it).

Then reinstall using:-

dpkg -i <packagename>

Domenico (waldo111) said : #4

Hi,
thanks for your attention, but I've already tried ro reinstall the package and the process fails because dpkg cannot find some dirs . Anyway I try another time to redownload the file before try ro reinstall, as you said, and then I'll refer the result.
Moreover I can't resolve Synaptic crash.

Best regards

Domenico

You can paste the results of your commands - even in Italian we can probably figure out what is happening.

TomLawell (talawell) said : #6

I am having the same Synaptic problem after trying to install the Brother 440cnlpr deb file.

Domenico (waldo111) said : #7

Ok, thanks a lot for your attention. I try to post error messages in italian language that occur when i try to install driver and cups wrapper for my Brother DCP750CW.
When I put the command line "sudo dpkg -i --force-all dcp750cwlpr-1.0.0-9.i386.deb" I receive the message
" Mi preparo a sostituire dcp750cwlpr 1.0.0-9 (con dcp750cwlpr-1.0.0-9.i386.deb) ...
/var/lib/dpkg/info/dcp750cwlpr.prerm: line 3: /usr/local/Brother/Printer/dcp750cw/inf/setupPrintcapij: Nessun file o directory
dpkg: attenzione - il vecchio script di pre-removal ha restituito un codice di errore 127
dpkg - provo quindi lo script dal nuovo pacchetto ...
/var/lib/dpkg/tmp.ci/prerm: line 3: /usr/local/Brother/Printer/dcp750cw/inf/setupPrintcapij: Nessun file o directory
dpkg: errore processando dcp750cwlpr-1.0.0-9.i386.deb (--install):
 il sottoprocesso nuovo script di pre-removal ha restituito un codice di errore 127
/var/lib/dpkg/info/dcp750cwlpr.postinst: line 3: /usr/local/Brother/Printer/dcp750cw/inf/setupPrintcapij: Nessun file o directory
Sono occorsi degli errori processando:
 dcp750cwlpr-1.0.0-9.i386.deb"

Other major problem I need someone help me, please:
when I start Synaptic I receive the message "E: Il pacchetto dcp750cwcupswrapper deve essere reinstallato, ma non si riesce a trovare un archivio per esso.
E: Errore interno aprendo la cache (1). Segnalare l'errore." I have already update /etc/apt/sources.list by "sudo apt-get update" and evrything seems to go ok, but the list of programs inside Synaptic manager is empty and Update manager crash with the same error message.

Thank you

Cesare Tirabassi (norsetto) said : #8

Domenico,

can you paste here the content of this file (if it is not too big):

/var/lib/dpkg/info/dcp750cwlpr.prerm

There is apparently a bad reference in line 3. We need to modify this script otherwise you will not be able to use anymore the package system.

Best Domenico (waldo111) said : #9

Hello,
I've solved the problem! Thanks a lot to all people answered my help request, particularly to Cesare Tirabassi; I've deleted all files related to DCP750CW driver inside inside dir "/var/lib/dpkg/info/" and Synaptic has started again to run normally. Then I've re-installed driver and now my printer Brother DCP-750CW works fine.