I need help mounting floppy

Asked by Harry Chestnut on 2006-12-16

I am very new to Ubuntu. Today, for the first, time I tried to write to a floppy. I have formatted it using the floppy formatter. However; I can't write to it. I don't know how. I tried to mount it in the terminal. (Ubuntu 6.06) This is what I got.
    $ mount /media/floppy0
mount: can't find /media/floppy0 in /etc/fstab or /etc/mtab

Will someone please tell me what I need to do.
    In advance I thank you. harry

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gnome-utils Edit question
Assignee:
No assignee Edit question
Solved by:
Ryan Kavanagh
Solved:
2006-12-17
Last query:
2006-12-17
Last reply:
2006-12-17

after trying many things I managed to mount the floppy. But when I try to write to it, I get the message error saving
General input output error.
     Again please help. Thanks harry

Luca Falavigna (dktrkranz) said : #2

Could you please attach the content of your /etc/fstab file?

This is the many ways that I have trieed to execute the command /etc/fstab.
harry@BOBJOE:~$ /etc/fstab
bash: /etc/fstab: Permission denied
harry@BOBJOE:~$ sudo /etc/fstab
Password:
sudo: /etc/fstab: command not found
harry@BOBJOE:~$ /etc/fstab
bash: /etc/fstab: Permission denied
harry@BOBJOE:~$ sudo /etc/fstab
sudo: /etc/fstab: command not found
harry@BOBJOE:~$ sudo /etc/fstab file
sudo: /etc/fstab: command not found
harry@BOBJOE:~$ sudo /etc/fstab
What am I doing wrong?

Thanks harry

Tim Rietmann (tsr-the-truth) said : #4

Harry,

/etc/fstab is a configuration file (in plain text format) which is used by the "mount" command. In order to display the contents of this file in your terminal window, just type:

cat /etc/fstab

in order to open it with the "gedit" text editor you need to type:

gedit /etc/fstab

if you want to save changes that you apply to that file, you will need to prefix the above command with "sudo" (don't yet do that in this stage, and always create a backup of this file when you edit it).

 -Tim

Here is the contents of that file.
# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
/dev/hda2 / ext3 defaults,errors=remount-ro 0 1
/dev/hda1 /media/hda1 vfat defaults,utf8,umask=007,gid=46 0 1
/dev/hda5 none swap sw 0 0
/dev/hdc /media/cdrom0 udf,iso9660 user,noauto 0 0

This is all new to me. I learned something similar about getting mh sound to work. Will I make a note of this so I will not need it a second time. thanks harry

Luca Falavigna (dktrkranz) said : #6

You should add the following line at the bottom of that file:
/dev/fd0 /media/floppy0 auto rw,user,noauto 0 0

In order to modify it, you have to open it using root privileges. You can do that by typing "sudo gedit /etc/fstab" in a console window, as stated by Tim.

Now you must check if /media/floppy0 directory is present with command "ls /media/floppy0". If you see "ls: /media/floppy0: No such file or directory" error message, you have to type "sudo mkdir /media/floppy0" in order to create it.

# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
/dev/hda2 / ext3 defaults,errors=remount-ro 0 1
/dev/hda1 /media/hda1 vfat defaults,utf8,umask=007,gid=46 0 1
/dev/hda5 none swap sw 0 0
/dev/hdc /media/cdrom0 udf,iso9660 user,noauto 0 0
Hi Tim
  here is what I tried, however i still get the error input output
error when I try to save to floppy,

harry@BOBJOE:~$ /dev/fd0 /media/floppy0 auto rw,user,noauto 0 0
bash: /dev/fd0: Permission denied
harry@BOBJOE:~$
harry@BOBJOE:~$ sudo gedit /etc/fstab
Password:
harry@BOBJOE:~$ sudo gedit /etc/fstab
Password:
Sorry, try again.
Password:
/media/floppy0
/media/floppy0
ls /media/floppy0
ls /media/floppy0
harry@BOBJOE:~$ /media/floppy0
bash: /media/floppy0: No such file or directory
harry@BOBJOE:~$ /media/floppy0
bash: /media/floppy0: No such file or directory
harry@BOBJOE:~$ ls /media/floppy0
ls: /media/floppy0: No such file or directory
harry@BOBJOE:~$ ls /media/floppy0
ls: /media/floppy0: No such file or directory
harry@BOBJOE:~$ sudo mkdir /media/floppy0
Password:
harry@BOBJOE:~$

Do I need t do something with the dir. I made. When I added the original line you suggested I saved it but not in the dir.. In addition I have been trying to write to floppy from open office. Maybe I am doing something wrong there. To make a back of the original file, the only place i could paste it to was here. there must be an easier way. Thank for your patience and support. In Jan. I will start a Linux adm. class. I love to learn. harry
and I am 61.
harry

Ryan Kavanagh (ryanakca) said : #8

Ok. Step by step, what you need to do:
1. Open a Terminal
2. Type: "sudo nano /etc/fstab <enter>" (Without quotation marks, replace <enter> by an "enter")
3. Use your arrow keys to move to the bottom of the file
4. Type in the following line:

/dev/fd0 /media/floppy0 auto rw,user,noauto 0 0

5. Go Ctrl-o (letter O, not zero), it will prompt:
"File Name to Write: /etc/fstab". Hit enter.
6. Go Ctrl-x . This will exit nano.
7. To mount a floppy, put a floppy in the floppy drive and run the command:
"mount /media/floppy0" (without quotation marks). If that fails,
"mount /dev/fd0 /media/floppy0" (again, no quotation marks).

You can now access your floppy in nautilus, konqueror, or your file browser.
To eject the floppy:
"umount /media/floppy0".
This will write the data onto the floppy.
Then press the eject button on your floppy drive and remove the floppy

quick explanation of:
/dev/fd0 /media/floppy0 auto rw,user,noauto 0 0

/dev/fd0 = the device
/media/floppy0 = Where you mount the device.
auto = automaticly detect filesystem... there are many filesystem types out there, this saves hassle.
rw = read & writre access, user = can be mounted by a user, noauto = mounted manually.

For more information on /etc/fstab and mounting, please see: http://www.tuxfiles.org/linuxhelp/fstab.html and http://www.tuxfiles.org/linuxhelp/mounting.html .

Cheers,
Ryan

Ir is me again. I did as you said and all seemed to work. However; I have the floppy icon on my title bar and it tells me that it is mounted, But it won't let me unmount it either with or with a floppy in the drive, I sincerely appreciate the commands that you explained in detail. Also, I still can't write to the floppy. Do I write to it by going file, save as, then choose floopy and click on save????????? I am ging to the URLs that you provided. It took me a week to get on the internet. Then 3 to get my sound. It took so long on that because, I didn't see if it was there when, will one you the people that work on launch pad. I am saving everything so I won't have to trouble you guys in the future with the same problem.
       Greatful harry

The last commands I used.

/dev/fd0 /media/floppy0 auto rw,user,noauto 0 0
  301 sudo gedit /etc/fstab
  302 /media/floppy0
  303 ls /media/floppy0
  304 sudo mkdir /media/floppy0
  305 sudo nano /etc/fstab <enter>
  306 sudo nano /etc/fstab enter
  307 history

Ryan Kavanagh (ryanakca) said : #10

Ah, On floppies, in the bottom right corner of the back of the floppy, there's usually a little tab/clip. Try sliding it to it to the bottom if it's at the top, and to the top if it's at the bottom. (It's a lock feature to prevent people from accidently rewriting important data). If that doesn't work, maybe you have a defective floppy (floppies tend to be unreliable).

Hope that helps,
Ryan

Best Ryan Kavanagh (ryanakca) said : #11

Sorry, missed a question of yours, you save a file to a floppy the same way as you would in windows. File, Save (or Save As...), Navigate to floppy, enter a filename, save. You can also copy / drag in drop files to it in Nautilus, Konqueror or Thunar.
If you wish to copy files by command line,
cp /path/to/file /media/floppy0/

cp = floppy
/path/to/file: where is the file located. If it's in your home directory, (/home/harry), you would use /home/harry/filename. if it's in a subdirectory, /home/harry/subdirector(y/ies)/filename
/media/floppy0/ : the directory where the floppy is mounted.

If you want to learn more about the linux shell and it's commands:
http://www.physics.ubc.ca/mbelab/berserk_doc/linux-intro/html/index.html
http://www.tuxfiles.org/linuxhelp/cli.html
http://www.linuxcommand.org/learning_the_shell.php

User confirmed that the request is solved.

Hi Ryan
   I am really learning. I am having a ball with the links you sent me. I have two simple questions. I only ask cause they will help me understand better. I realize that cat needs to be in front of, /etc/fstab, to bring it up. Will you please take the time to explain why and what it means. The other question, do I need both of the identical items listed below, if so why. Or can I use sudo to delete one of them. They are both in the file.

/dev/fd0 /media/floppy0 auto rw,user,noauto 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto 0 0

Learning all this is exciting. Thanks harry

Ryan Kavanagh (ryanakca) said : #14

Hey Harry,
The 'cat' manpage (available with 'man cat') (manpage = manual for a command) describes:

CAT(1) User Commands CAT(1)

NAME
       cat - concatenate files and print on the standard output

SYNOPSIS
       cat [OPTION] [FILE]...

DESCRIPTION
       Concatenate FILE(s), or standard input, to standard output.

That explains what 'cat' means (conCATenate)....

The Synopsis also describes how to use the command cat.

cat [place any options here, see the manpage for more info] [file (in your case /etc/fstab)]

You should be able to delete one of the lines, using nano, as described earlier.
Feel free to join us on irc.ubuntu.com, port 8001, #ubuntu for real time support. https://help.ubuntu.com/community/XChatHowto

The New User Network (NUN) has also been hosting ubuntu classes every other weeks, see
https://wiki.ubuntu.com/Classroom

Enjoy,
Ryan

In the future I will try to look up more and not take up your valuable time with minor questions.
     I am certainly enjoying. harry

itodrona (itodrona) said : #16

Hi Harry
I am unable to mount the cdrom? can you help me please? I ma new to the ubuntu environ.

I am in micrsoft school. At present I am not using UBUNTU, I do not remember. Keep posting someone will answer you. I will get back to Ubuntu when I finish school UBUNTU is real cool. harry

> To: <email address hidden>> From: <email address hidden>> Subject: Re: [Question #2830]: I need help mounting floppy> Date: Tue, 11 Sep 2007 07:18:33 +0000> > Your question #2830 on gnome-utils in ubuntu changed:> https://answers.launchpad.net/ubuntu/+source/gnome-utils/+question/2830> > itodrona posted a new comment:> Hi Harry> I am unable to mount the cdrom? can you help me please? I ma new to the ubuntu environ.> > -- > You received this question notification because you are a direct> subscriber of the question.
_________________________________________________________________
Capture your memories in an online journal!
http://www.reallivemoms.com?ocid=TXT_TAGHM&loc=us

miketan63 (miketan63) said : #18

Floppy Activation for Ubuntu 8.10 – 20 Feb 2009 - <email address hidden> (Windows,Macintosh,Linux)

Run Update Manage & Reboot

1. Run (Alt + F2) : gksu gedit /etc/modules

1A. For msdos usage - Add the line :

      floppy

      to the end of the list. Save the file & Close document.

OR

1B. For Linux Native (ext2) usage - Add two lines :

      #To load floppy module

      floppy

      to the end of the list. Save the file & Close document.

1C. Reboot

2. Run : sudo mkdir floppy0

                 sudo chmod g+rwx floppy0

                 sudo chmod o-rx floppy0

                 sudo modprobe floppy

                 sudo mount /dev/fd0 floppy0

2A. Reboot

3. Go to Main Menu : System/Administration/Synaptic Package Manger - Quick search -

     type floppy - Check - fdflush / fdutils - Mark for Installation - Apply

3A. Reboot

4. To activate Floppy Formatter :

     In a Root Terminal , type : sudo gfloppy (enter)

5. To mount floppy : Right Click on Floppy Drive - Mount - in Nautilus (File Browser).

     Do not use Double Click.

     To open floppy : Double Click or Right Click - Open. Umount floppy after use.

6. Works alright on Quick Format but not so on Standard , Thorough , ext2 for all the

     above command. Still some bugs, hopefully subsequent updates could be corrected.

7. Reboot if floppy unable to mount or fail.