Operação requer privilégios de superutilizador

Asked by João Fernando Machado Mão de Ferro on 2008-01-21

No gestor de actualizações aparece o seguinte:

E: dpkg was interrupted, you must manually run dpkg --configure -a to correct the problem

E:_cache>open()failed please report

Digito na consola o comando dpkg --configure -a

aparece o seguinte: dpkg: a operação requisitada requer privilégios de superutilizador

Todo este problema de não poder fazer actualizações começou por ter havido um arranque falhado, não sei como resolver os privilégios de superutilizador se é que é o suficiente

Estou a usar o Linux 7.10 Ubuntu

Question information

Language:
Portuguese Edit question
Status:
Solved
For:
Ubuntu gnome-utils Edit question
Assignee:
No assignee Edit question
Solved by:
João Fernando Machado Mão de Ferro
Solved:
2008-01-22
Last query:
2008-01-22
Last reply:
2008-01-22
Rodrigo Donado (frezeeer) said : #1

Hola:

Abre una terminal y escribe:
sudo dpkg --configure -a

espero que te ayude, tienes que poner tu contraseña otra vez

Obtenho a seguinte resposta

sudo password for jfmmf:

E não consigo escrever mais nada

Marco Rodrigues (gothicx) said : #3

Quando aparece essa mensagem, digita a password do utilizador jfmmf e depois ENTER. Não irá aparecer a password ao digitá-la.

Os meus sinceros agradecimentos pela vossa imediata disponibilidade que é uma grande ajuda principalmente para quem é iniciante no Linux Ubuntu, fazendo para que haja mais apoiantes deste sistema

Se me permite acrescento mais uma pequena informação é de que além de não aparecer a chave não aparece espaços asteriscos e o próprio cursor não avança assim para um outro principiante tendo problema semelhante não fica atrapalhado ao ver que não consegue escrever nada

                                                   Atenciosamente
                                   João Fernando Machado Mão de Ferro

joao mendes (ct1gma) said : #5

tenho o unbutu 8.04 preciso de instalar uma drive duma impressora , um ficheiro ...tar.gz descomprimi-o ficou ....gz.sh
faço : sudo apt-get install z600cups-1.0-1.gz.sh diz-que não encontra o directorio. Já tentei de tantas maneiras e não consigo. Alguém me pode ajudar?

         João Mendes