Application>Office>Dictionary is not working-Lookup failed for host ' dict.org': Unknown error

Asked by Tycdum on 2011-04-04

In application> Office>Dictionary when I type a word I receive =)ookup failed for host ' dict.org': Unknown error
I need help?
My dictionary do not give solutions to the problem

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gnome-utils Edit question
Assignee:
No assignee Edit question
Solved by:
Sam_
Solved:
2011-04-05
Last query:
2011-04-05
Last reply:
2011-04-04
Sam_ (and-sam) said : #1

Confirmed on 10.10
$ gnome-dictionary ## insert: dictionary
Error while looking up definition
Connection failed to the dictionary server at dict.org:2628

.xsession-errors
(gnome-dictionary:14520): Gdict-WARNING **: Attempting to retrieve the available databases, but no GdictContext has been set. Use gdict_database_chooser_set_context() before invoking gdict_database_chooser_refresh().

ping works.
ping -c 4 dict.org
PING dict.org (216.93.242.2) 56(84) bytes of data.
64 bytes from miranda.org (216.93.242.2): icmp_req=1 ttl=54 time=109 ms
64 bytes from miranda.org (216.93.242.2): icmp_req=2 ttl=54 time=110 ms
64 bytes from miranda.org (216.93.242.2): icmp_req=3 ttl=54 time=110 ms
64 bytes from miranda.org (216.93.242.2): icmp_req=4 ttl=54 time=108 ms

Best Sam_ (and-sam) said : #2

What I did now, without extra installing anything, I've choosed a different server, but left the port 2628.

Edit -> preferences -> source -> add
Discription: <any name>
Transport: leave Dictionary Server
Hostname: insert a server of your choice

## Example hostname which worked here was: dict.hewgill.com
http://hewgill.com/dict/

Which I took from the list of dict servers there.
http://luetzschena-stahmeln.de/dictd/index.php
http://www.dict.org/links.html

Just in case firestarter is blocking your port.
http://www.linuxquestions.org/questions/fedora-35/gnome-dictionary-2-8-0-toolbar-applet-cant-find-host-305952/

btw. wishlist for usage offline.
Bug #19227

For what it's worth.
If nothing helps maybe you need to install extra packages.
Install them via SoftwareCenter or Synaptic.
dictd and recommended packages
dict-gcide or dict-wn
There is also a list of dictionaries (see blue icon) dictd-dictionary, so you may note the package you'd like and install via package manager.
http://packages.ubuntu.com/maverick/dictd

Tycdum (tycdum) said : #3

I have follwed your advice with dict.hewgill.com and it works well
Thanks