Application>Office>Dictionary is not working-Lookup failed for host '': Unknown error

Asked by Tycdum on 2011-04-04

In application> Office>Dictionary when I type a word I receive =)ookup failed for host '': Unknown error
I need help?
My dictionary do not give solutions to the problem

Question information

English Edit question
Ubuntu gnome-utils Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Sam_ (and-sam) said : #1

Confirmed on 10.10
$ gnome-dictionary ## insert: dictionary
Error while looking up definition
Connection failed to the dictionary server at

(gnome-dictionary:14520): Gdict-WARNING **: Attempting to retrieve the available databases, but no GdictContext has been set. Use gdict_database_chooser_set_context() before invoking gdict_database_chooser_refresh().

ping works.
ping -c 4
PING ( 56(84) bytes of data.
64 bytes from ( icmp_req=1 ttl=54 time=109 ms
64 bytes from ( icmp_req=2 ttl=54 time=110 ms
64 bytes from ( icmp_req=3 ttl=54 time=110 ms
64 bytes from ( icmp_req=4 ttl=54 time=108 ms

Best Sam_ (and-sam) said : #2

What I did now, without extra installing anything, I've choosed a different server, but left the port 2628.

Edit -> preferences -> source -> add
Discription: <any name>
Transport: leave Dictionary Server
Hostname: insert a server of your choice

## Example hostname which worked here was:

Which I took from the list of dict servers there.

Just in case firestarter is blocking your port.

btw. wishlist for usage offline.
Bug #19227

For what it's worth.
If nothing helps maybe you need to install extra packages.
Install them via SoftwareCenter or Synaptic.
dictd and recommended packages
dict-gcide or dict-wn
There is also a list of dictionaries (see blue icon) dictd-dictionary, so you may note the package you'd like and install via package manager.

Tycdum (tycdum) said : #3

I have follwed your advice with and it works well