how do you get file sharing to work on ubuntu!!?

Asked by jordan Housewright on 2010-06-09

this feature cannot be enabled because the required packages are not installed on your system

i get this when trying to get the file sharing i always run into this, but i don't know what "packages" i need. i have a lot of movies on my computer and i used to share them with everyone in the house when i was running windows. i really love ubuntu but i can't get this to work and it kinda is pissing me off.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gnome-user-share Edit question
Assignee:
No assignee Edit question
Solved by:
jordan Housewright
Solved:
2010-06-09
Last query:
2010-06-09
Last reply:
2010-06-09

sorry i forgot to add that im running ubuntu 10.04

David Jones (dj) said : #2

The files that you will have to install are:

    * apache2.2-bin
      Apache HTTP Server common binary files

      The Apache Software Foundation’s goal is to build a secure, efficient and
      extensible HTTP server as standards-compliant open source software. The
      result has long been the number one web server on the Internet.

    * libapache2-mod-dnssd
      Zeroconf support for Apache 2 via avahi

      mod_dnssd is an Apache HTTPD module which adds Zeroconf support
      via DNS-SD using Avahi. This allows Apache to advertise itself and the
      websites available to clients compatible with the protocol.

Install both from the synaptic package manager, and reboot after you have installed. Once you have rebooted the computer, you will be able to enable the personal file sharing for Ubuntu 10.04

   David
   in TN

thank you vary much !!!!

i don't know if your part of the team that made ubuntu but i think this should be included with the next update/version of the OS

@David i'm confused please tell why apache2 to share files... instead of samba...?

Thank you

destroyedlolo (destroyedlolo) said : #5

@marcobra : because it uses webdav protocol instead of SMB ...