Unable to complete the installation of downloaded TrueCrypt file encryption package

Asked by John Spicer on 2009-11-28

Am using Ubuntu 9.10. For TrueCrypt, I downloaded the Ubuntu -x86.deb version to the desktop. File name is truecrypt-6.3a-ubuntu-x86.tar.gz
In the terminal I entered $ sudo apt-get install dmsetup ( OK)
Then $ tar zxf ~/Desktop/truecrypt-6.3a-ubuntu-x86.tar.gz (Failed. "Cannot open.No such file or directory....tar exiting with failure status due to previous errors")
Then $ sudo dpkg -i truecrypt-6.3a/truecrypt_6.3a-0_i386.deb (Failed, "cannot access archive. No such file or directory")
So then I switched (hopefully!) to synaptic with $ sudo synaptic -i truecrypt-6.3a/truecrypt_6.3a-0_i386.deb (This opened the Synaptic panel and offered two options, ie. "ezycrypt" and "gdecrypt" I installed the former.)
Resulting message box said "Could not open the file /home/<my name>/truecrypt-6.3a-setup-ubuntu-x86 using the Unicode (UTF-8) character coding. Please check that you are not using a binary file " (how??) Then re-tried following character codes ISO-8859-1, ISO 8859-15, Windows-1252, IBM 850 None worked.

Anyone know what I should do next?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gnome-terminal Edit question
Assignee:
No assignee Edit question
Solved by:
Omer Akram
Solved:
2009-11-29
Last query:
2009-11-29
Last reply:
2009-11-28
Best Omer Akram (om26er) said : #1

try install easycrypt it is a frontend to true crypt. sudo apt-get install easycrypt

Assuming you are using the 32 bit Ubuntu
Please open a terminal and copy and paste from here a row a time then press enter:

mkdir truecrypt
cd truecrypt
wget http://www.truecrypt.org/download/truecrypt-6.3a-ubuntu-x86.tar.gz
tar xvzf truecrypt-6.3a-ubuntu-x86.tar.gz
./truecrypt-6.3a-setup-ubuntu-x86

From the window that come in front of you select install package

Hope this helps

John Spicer (jay-ess) said : #3

Thanks om26er, that solved my question.

John Spicer (jay-ess) said : #4

Marco, I struck a problem in the fourth line of your solution. Terminal said "command not found you must specify one of the -Acdtrux options" So I amended the line to read tar ovzf truecrypt-6.3a-ubuntu-x86.tar.gz
That worked fine. Thanks for you help. I learned about tar from it.