"sudo app install" fails to take password while giving

Asked by Md. Sahadat ullah

Binary package hint: gnome-terminal

while trying to install winrar380, I am giving command in terminal "sudo app get install", then it wanting system pasword. When I am typing my password it can't showing on the screen, looks like nothing typed. Therefore I can not install. Please help me...

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 9.04
ExecutablePath: /usr/bin/gnome-terminal
Package: gnome-terminal 2.26.0-0ubuntu2
SourcePackage: gnome-terminal
Uname: Linux 2.6.28-13-generic i686

Question information

English Edit question
Ubuntu gnome-terminal Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
Md. Sahadat ullah (mdsahadatullah) said :
Revision history for this message
swoody (swoody) said :

Thank you for taking the time to report this bug! However, it is not supposed to display anything when you type in your password. It will look like nothing's there. This is for security purposes. You really are typing in your password, and it really is accepting it, though. So try it again, this time type in your password just as you normally would, and hit 'Enter' after it. This should make it go through unless there is something wrong with your system.

Try it out, and post back here with your results.

Revision history for this message
Chris Coulson (chrisccoulson) said :

Thank you for taking the time to report this issue and helping to make Ubuntu better. Examining the information you have given us, this does not appear to be a bug report so we are closing it and converting it to a question in the support tracker. We appreciate the difficulties you are facing, but it would make more sense to raise problems you are having in the support tracker at https://answers.launchpad.net/ubuntu if you are uncertain if they are bugs. For help on reporting bugs, see https://help.ubuntu.com/community/ReportingBugs .

Revision history for this message
Vihar (vmankov) said :
Revision history for this message
Best actionparsnip (andrew-woodhead666) said :

if you run:

sudo apt-get install unrar rar

You can now handle rar files just fine

WinRAR is for windows.

When you type your password, nothing s shown. This is a security feature so people cannot see the length of your password when using the terminal. This is kinda pointless though, as when gksudo or kdesudo are used, the length is visible

Oh well.

Revision history for this message
Md. Sahadat ullah (mdsahadatullah) said :

Thanks actionparsnip, that solved my question.